Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with the language support in Ubuntu 12.04LTS. I want to install Spanish in my computer and the system isn't able to find or create the directory that will allow the system to actually set Spanish as a language option inside Language support. So I am wondering how can I tell the system where are those files or how to fix this in any other way.

Thanks a lot!

share|improve this question
up vote 3 down vote accepted

Try the following command on the terminal windows (CTRL+ALT+T)

export LANG=es_ES.ISO-8859-1
export LANGUAGE=es_ES:en
export LC_CTYPE=es_ES.ISO-8859-1
export LC_NUMERIC=es_ES.ISO-8859-1
export LC_TIME=es_ES.ISO-8859-1
export LC_COLLATE=es_ES.ISO-8859-1
export LC_MONETARY=es_ES.ISO-8859-1
export LC_MESSAGES=es_ES.ISO-8859-1
export LC_PAPER=es_ES.ISO-8859-1
export LC_NAME=es_ES.ISO-8859-1
export LC_ADDRESS=es_ES.ISO-8859-1
export LC_TELEPHONE=es_ES.ISO-8859-1
export LC_MEASUREMENT=es_ES.ISO-8859-1
export LC_ALL=

sudo update-locale LANG=es_ES.ISO-8859-1
share|improve this answer
it doesn't work: *** update-locale: Error: invalid locale settings: LC_TELEPHONE="en_CA.UTF-8" LANGUAGE="en_GB:en_AU:en_CA:en" LC_MONETARY="en_CA.UTF-8" LC_ADDRESS="en_CA.UTF-8" LC_PAPER="en_CA.UTF-8" LC_NAME="en_CA.UTF-8" LC_NUMERIC="en_CA.UTF-8" LC_MEASUREMENT="en_CA.UTF-8" LC_TIME="en_CA.UTF-8" LANG=es_ES.UTF-8 LC_IDENTIFICATION="en_CA.UTF-8" here what it says – Jeff Labonte Oct 6 '12 at 14:52
still trying and it still says the same thing =( – Jeff Labonte Oct 6 '12 at 14:57
Reading package lists... Done Building dependency tree Reading state information... Done locales is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not is already installed, if I unistall it and reinstall it would it help? – Jeff Labonte Oct 6 '12 at 14:59
Than you! I have solved my problem. I reinstalled the locales and then everything worked! thank for your help! – Jeff Labonte Oct 6 '12 at 15:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.