Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I need to specify that this is not a duplicate of this:
How do I turn off wireless connection notifications?

Neither is this a duplicate of this:
How to disable notification from network-manager

What I am asking has to do with Ubuntu 12.04 LTS
and not the notifications but this program I think it is apport but not sure that is responsible for the "wireless authentication required" windows shown below:

enter image description here

Please tell me how I can turn these off. When I go to sleep and leave wireless on, I get HUNDREDS of these . Hundreds!!! And then I have to close each one individually which takes sometimes several minutes of clicking through them. Sometimes My computer wont even wake from sleep due to the amount of ram consumed by the hundreds of these windows.

I often forget to turn my wireless off before I sleep. I try to do it and that will negate this problem but I shouldn't have to make a conscious decision to do that every time. I want to leave my wireless on and I don't want to get these windows.

AT THE VERY LEAST, You only need to get one window asking for a password from ONE network right? BUT I get hundreds of these windows asking for a password for THE SAME NETWORKS!!!!!

help!

Specifically I would like to fix this problem while allowing me to leave my wireless connection on while I sleep and not have to put my computer into hibernation.

share|improve this question
2  
add comment

3 Answers

up vote 3 down vote accepted

As @devav2 said this is a bug. I found it here

Workaround for not nm-applet asking for the keyring all the time is to go to NetworkManager (nm-connection-editor) & remove wireless networks that are not currently in use or those wireless networks one doesn't have access to.

share|improve this answer
1  
This almost works except, I can't "forget" the one wireless connection that I use. So, what ends up happening is, I get tons of windows for that one wireless connection that I want to remember. This workaround ALMOST worked though. My home modem is on a timer so after 12:00am it automatically shuts off so no one can use it. But sometimes I'm asleep before that time. This is the one network that I don't want to forget... anyways. Hope they fix the bug soon even though it has been a known registered bug for almost a year now. –  Joshua Robison Oct 6 '12 at 23:27
add comment

Ok I solved this bug... finally! Delete all the internet connections that you have, even the one you are using. Restart the computer. Now when u start it up again ubuntu will change some of the settings for wireless connection and it will "fix itself". If ubuntu doesnt find your wireless connections, type it in manually by "edit connections".

This solved the bug for me. The idea is that you delete settings that u had in an earlier version of ubuntu, causing the new version of ubuntu to ask for password indefinately. When u delete all the connections the new version gets to find these settings by itself.

share|improve this answer
add comment

It's not a solution to the bug, but the multiple windows can quickly be gotten rid of via the killall nm-applet command in a terminal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.