Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I installed 12.04, I think waiting a long time to choose between Windows 7 and Ubuntu is such a waste.

So I went into Windows 7 and set the default to Ubuntu and no waiting time (not the grub in Ubuntu). Now I can only access Ubuntu but I have something to do with Windows 7. I wonder how can I enter Windows 7?

There is no Windows 7 in my Grub menu. Even if I add one in, It said no such thing. Since this is Windows 7, I can't edit boot.ini to fix it.

I have tried to punch F8 or the down arrow to stop the system turn to Ubuntu but, they all failed. I just want to enter Windows 7 and change that damn waiting time.

share|improve this question
1  
Which tool did you use set the default to Ubuntu in Windows? –  Emerson Hsieh Oct 5 '12 at 23:17
    
And type sudo update-grub to make the windows option to show in GRUB again, but you still have to wait –  Emerson Hsieh Oct 5 '12 at 23:19
1  
If you had used Grub2, to default to Ubuntu (with no wait time), then you just need to hold down the 'Shift'-key (on startup) to see the Grub2 menu. –  david6 Oct 5 '12 at 23:53
    
@EmersonHsieh I use BSD in windows7 to set the default to Ubuntu. –  user94840 Oct 6 '12 at 8:46
    
I have tried Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.0-31-generic-pae Found initrd image: /boot/initrd.img-3.2.0-31-generic-pae Found linux image: /boot/vmlinuz-3.2.0-29-generic-pae Found initrd image: /boot/initrd.img-3.2.0-29-generic-pae Found Windows 7 (loader) on /dev/sda1 Skipping Windows 7 (loader) on Wubi system done I wonder is this skipping message let win7 disappear from grub. –  user94840 Oct 6 '12 at 8:49

2 Answers 2

This is actually a Windows 7 / MBR problem.


STRONG CAVEATS

  • I have not tried this, as I have always used Grub for dual-boot of Ubuntu and Windows.

  • Check that you have backup copies of any critical settings and user data before proceeding.


If you 'Restore your MBR", then Windows should boot normally.

Restore the Windows bootloader to MBR after dual-booting with Linux

Note: Some of the Windows-centric recommendations herein don't make total sense (IMHO), but the technical steps seem fairly straight forward ..

I then suggest you force re-install of Grub2 (for dual-boot).

share|improve this answer

Try removing your Hard drive or other boot device, that way it will either stay on the main bios screen or give you an error message that will let you enter setup/bios menu.

share|improve this answer
    
I think you didn't get the point on what the problem is in this question. Nevertheless thank you for your efforts trying to provide some help. –  Geppettvs D'Constanzo Oct 6 '12 at 1:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.