Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Xubuntu on my computer. I love the distro. Everything was fast, and then the bootup slowed down. It started taking a couple minutes for my user selected wallpaper to show and the menu to appear, basically do anything on the comp. I do not recall doing anything other than changing the swappiness. It did not affect it initially. Would that be something to affect it or are there other ideas that might have caused this sudden change.

share|improve this question

2 Answers 2

Yes, changing swappiness can slow down your computer. It is the threshold at which the system will swap data from the ram to the hard drive in order to preserve space. Data can be found, read and written much faster in memory than on the hard drive. Therefore it is best to keep data in memory and only swap to the hard drive when memory is very low. By default, swappiness is set to 60 and changing this value will determine how the system behaves in these situations.

Increasing this value will cause the system to swap more often. Even when it may be unnecessary. It will be more likely that the data you are seeking has been swapped out of memory. As I said earlier file manipulation is much slower on a hard disk so even simple tasks may take much longer than normal to complete.

Decreasing this value will cause the system to avoid swapping data to the hard disk. Sometimes this is recommended to increase performance but this could backfire if you have little ram to begin with. So, low ram combined with a low swappiness value can result in a system that will run out of memory quickly, while being reluctant to free memory through swapping.

I would recommend that you return the swappiness value to the default of 60. Monitor how the computer behaves. Hopefully you will see improvement.

share|improve this answer
    
Going to switch it back. I did find this though... bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/996791 –  Bryan Oct 6 '12 at 1:28
    
Do you have Lightdm logs that look like that? –  matt davis Oct 6 '12 at 1:33
    
I do not know how to check. –  Bryan Oct 6 '12 at 13:15
    
It is located at /var/log/lightdm/lightdm.log. Any time you hear something about log files 99% of the time it will be in /var/log. Run 'gksu leafpad /var/log/lightdm/lightdm.log' in terminal to view it. –  matt davis Oct 6 '12 at 14:29
    
Ok. Give me a bit. I reinstalled and now am getting grub rescue errors. Tried reinstalling and it is not reading the thumb drive. I reinstalled because I know it was caused by an update now. Was just trying to narrow it down. –  Bryan Oct 6 '12 at 14:52

I have xubuntu on a PC with 512MB RAM. It is slow, but it has improved a little after following this: http://linux-software-news-tutorials.blogspot.it/2011/10/xubuntu-too-slow-heres-how-to-speed-it.html I suggest the option described should be disabled by default on the next xubuntu versions.

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  hhlp Dec 31 '12 at 12:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.