Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I purchased a new Lenovo g580 laptop. But I am totally disappointed when I installed Ubuntu on it. Almost all drivers are not working. :-( The laptop configuration is intel i3 processor Nvidia GeForce 610M graphics card.

I couldn't find the nvidia drivers in the additional drivers (jockey). The main problem is that the brightness control not working. I tried lots of methods explained in this site, but the result again disappointed me.

I am a student and I am using Linux, and the brightness control is the most urgent problem that have to be solved.

So experts please give me a solution.

thanks in advance

share|improve this question

Try adding the following line to /etc/X11/xorg.conf in the "Device" section for your GPU:

Option "RegistryDwords" "EnableBrightnessControl=1"

Then restart X and see if the brightness controls work. Probably the easiest way to restart X is to simple reboot the computer.

Source here.

share|improve this answer

It's hard to tell what the problem is only with that information.

You could start by looking the directories under /sys/class/backlight/ there should be a couple of them.

Try to set the brightness by manually changing the file "brightness" in one of these directories (you have to do it as root)

share|improve this answer
The problem is simply i cannot control the brightness using the function keys. – shijo Oct 5 '12 at 18:36
Which version of ubuntu? (10.04/10.10/11.04/11.10/12.04/12.10/13.04) – GM-Script-Writer-62850 Apr 28 '13 at 14:15

Alternatively you can install xbacklight from USC and setup a start up entry with the command xbacklight -set % where you put your numbers in place of %

share|improve this answer

Try this, it may solve you problem.It solved my problem on Acer aspire 4736 :

Open terminal by hittin Ctrl+Alt+t and apply this command.

sudo setpci -s 00:02.0 f4.b=xx

Here replace xx between 00[Bright] to ff[Dark]. It is a hexadecimal value that control your brightness.

For more information visit this link.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.