Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell D610 which I have just dual booted with Ubuntu 12.04 LTS.

I get Network->Wireless-> "Firmware missing" in Ubuntu but wireless OK with XP.

Using a terminal I find the Broadcom device is: BCM4306 [14e4:4324] rev 03.

I tried "sudo apt-get install firmware-b43-installer" and got "An unsupported BCM4301, BCM4306 or BCM4306/2 device was found. Use b43legacy firmware (firmware-b43legacy-installer package) instead. Aborting."

I then removed this half installed package.

Then I did "sudo apt-get install firmware-b43legacy-installer".

Appeared to install but I still get "Firmware missing".

I've tried rebooting but no good.

share|improve this question
    
Can you post the output of the installation command. –  mikewhatever Oct 5 '12 at 17:25
add comment

1 Answer

It looks like you have determined that the open source firmware for your 4306 does not work (even though the docs indicate the 4306 is supported). Next, try the Broadcom firmware -- accept the offer to download files when installing the b43-fwcutter package:

sudo apt-get install b43-fwcutter

The download offer is only given the first time the package is installed, so if you have already refused the download, do a purge (not just a remove) and install again.

sudo apt-get purge b43-fwcutter sudo apt-get install b43-fwcutter

The open source firmware and Broadcom firmware get installed into different directories, and when both are present, the Broadcom version (in /lib/firmware/b43) is used.

With the firmware in place, NetworkManager may start scanning, if not, manually load the b43 driver module, or just reboot.

sudo modprobe b43

NetworkManager should start scanning and offer a list of possible connection points within a few seconds.

Select your access point, select the correct encryption method, and enter your key. If you are not broadcasting your ssid and it does not show up in the list of access points, you might have to left click NetworkManager and select the menu item "connect to hidden network", and enter your ssid. Next boot, the connection should be automatic.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.