Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night I did an update and reboot. After that, I couldn't reliably play any flash videos. They would either go too fast or stutter (as if they were buffering every 2 seconds). This occurs in both Firefox and Chrome, however I'll troubleshoot in Chrome because it's easier to enable/disable plugins at will.

With PPAPI enabled (and npapi disabled), flash videos play at 1.5x speeds and audio is scrambled.

With NPAPI enabled (and ppapi disabled), flash videos stutter and skip, despite showing a decent buffer.

From one old thread, I went into pavucontrol and tried disabling the high def audio controller. I also tried disabling Totem plugin to no affect.

Version other details:

Linux freshdesk 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

Shockwave Flash 11.3 r31
/opt/google/chrome/PepperFlash/libpepflashplayer.so
11.3.31.331  PPAPI (out-of-process)

Shockwave Flash
Version:    11.2 r202
Location:   /usr/lib/adobe-flashplugin/libflashplayer.so
Type:   NPAP

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
share|improve this question
    
Well.. after 2 reboots, everything started working again. The system became practically unresponsive, forcing me to do a hard reboot. When it came up, flash seemed to be working properly, but no sound (in fact, sound settings was not showing any audio hardware). A graceful reboot later, and everything seems to be working again. I'd say the two threads I linked to should work for most people, and I had some transient error. –  ytjohn Oct 21 '12 at 15:23
add comment

1 Answer

The problem of videos playing/stuttering very quickly, like a fast-forward VHS, might be solved by disabling pulseaudio.

Trypulseaudio -k in terminal. You should see all sound die for a second or two. See if the video plays correctly right after that. If that fixes it, it will probably start having issues again later. I used this guide to replace pulseaudio with the alsa audio component, and it's worked fine for me ever since. (Ubuntu 12.04)

share|improve this answer
    
Thanks for the info. Actually my system started working again after 2 reboots (see comment on question). –  ytjohn Oct 21 '12 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.