Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I've installed netatalk from sources on my home server. Few days ago I've tried to install some packages using apt-get but I've got a message about broken dependencies.

The following packages have unmet dependencies:
 krb5-multidev : Depends: libkrb5-3 (= 1.9.1+dfsg-1ubuntu2.3) but 1.10.1+dfsg-2 is to be installed
             Depends: libgssapi-krb5-2 (= 1.9.1+dfsg-1ubuntu2.3) but 1.10.1+dfsg-2 is to be installed
 libc-dev-bin : Depends: libc6 (< 2.14) but 2.15-0ubuntu15 is to be installed
            Recommends: manpages-dev but it is not going to be installed
 libc6-dev : Depends: libc6 (= 2.13-20ubuntu5.1) but 2.15-0ubuntu15 is to be installed
 libnih1 : Depends: libc6 (< 2.14) but 2.15-0ubuntu15 is to be installed
 ushare:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
           Depends: libdlna0:i386 but it is not going to be installed
           Depends: libupnp3:i386 (>= 1.4.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

sudo apt-get -f install wants to completely remove all packages I've got installed on my system. What can I do?

share|improve this question

migrated from serverfault.com Oct 5 '12 at 13:50

This question came from our site for system and network administrators.

First, you do what it told you to do:

Try 'apt-get -f install' with no packages (or specify a solution).

(This message is from Debian; you should actually run sudo apt-get -f install.)

If this doesn't correct the problem, then do all of the following:

  1. Check /etc/apt/sources.list and make sure you are on a single version (e.g. precise) and haven't tried to mix in sources from e.g. quantal, etc.
  2. Disable any third party PPAs you may be using.
  3. Run sudo apt-get clean.
  4. Run sudo apt-get update.
  5. Run sudo apt-get dist-upgrade.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.