Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with the newest Ubuntu-version (12.04). I want to use the FN-Keys to adjust the brightness of my screen, but it doesnt work. Normally it should be FN+left arrow/right arrow. However adjusting the volume with FN+ up arrow/down arrow works fine.

I already searched for a few soulutions, for example tried to replace in the Grub-File

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash cpi_osi=Linux"

but it all doesn't work for my laptop. How can I fix this problem?

share|improve this question
    
This may help you: askubuntu.com/questions/56155/… –  Weylin Schreck Oct 5 '12 at 10:06
    
Thank you for your answer. The link you gave me looks useful, but I dont know how to do it. I installed xdotool, but it only works, if I write it in the terminal. If I want to make a new shortcut (in the system configuration) it doesnt work. Regarding the solution of sagarchalise and Michał Šrajer: i found the sys/class/blacklight/acpi_video0/brightness witht the number 15, but I dont know what to do. There is no explanation. –  richter12 Oct 5 '12 at 15:52

2 Answers 2

Couldn't change graphics with Fn keys on my Acer laptop.

This helped me (notice a little bit different parameter), added to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

Then runupdate-grub and reboot.

Source: http://www.refreshit.info/2012/08/solved-brightness-increase-and-decrease.html

share|improve this answer

I had exactly the same problem running ubuntu 13.10 on an Acer laptop. Editing the grub file enabled me to change the brightness through the control panel, but not with the FN+ left/right arrow.

It turned out that the evildoer in my case was TLP (https://github.com/linrunner/TLP). I solved the issue by editing /etc/default/tlp and changing

PCIE_ASPM_ON_AC=performance

to

PCIE_ASPM_ON_AC=default
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.