Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I change the grub boot order?

O.K., I follow How to set default boot kernel in Ubuntu / Grub? and make a mistake. I didn't count the entry from 0... I want to set default boot kernel as Linux 3.2.17-chipsee, count it (begin from 1) from the top, and I get 3. It seems grub will skip those menuentry with recovery mode, and select memtest as default boot option. Now when I boot the machine, it cannot skip memtest. After memtest is done, the machine still reboot into memtest. How can I fix this mistake? I try to boot Ubuntu from the cd-rom, and edit /etc/default/grub file on the disk. But it told me that's read-only... Thanks.

$ grep menuentry /boot/grub/grub.cfg
menuentry 'Ubuntu, with Linux 3.2.17experimental' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry 'Ubuntu, with Linux 3.2.17experimental (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry 'Ubuntu, with Linux 3.2.17-chipsee' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry 'Ubuntu, with Linux 3.2.17-chipsee (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry 'Ubuntu, with Linux 3.2.0-23-generic' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry 'Ubuntu, with Linux 3.2.0-23-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
share|improve this question

marked as duplicate by Anwar Shah, Mitch, SirCharlo, Marco Ceppi Oct 5 '12 at 17:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers 2

From the https://help.ubuntu.com/community/Grub2

You can change which kernel grub boots to during the computers start-up.

As the computer starts up.

Hold down SHIFT to display the menu during boot. In certain cases, pressing the ESC key may also display the menu.

enter image description here

You should now see the the grub menu. Use the arrow keys to navigate to the correct kernal to boot. Then follow instructions in the above post.

Then follow the instructions in this post to fix the menu entry.

Or try the ubuntu community documentation here. https://help.ubuntu.com/community/Grub2/Setup#Configuring_GRUB_2

share|improve this answer
    
Actually, I did try hold SHIFT, but it doesn't work. Maybe I should press ESC instead. Anyway, I re-install the system... Thanks. –  chenwj Oct 5 '12 at 10:06
    
one of the first changes I make to my installations is to add a longer time out and to show the menu by default. I am a bit of an experimenter, and like to be able to make changes easily. @chenwj –  nelaar Oct 5 '12 at 10:12
add comment

There's a tool called grub customizer that can edit and set the default boot option.

https://launchpad.net/grub-customizer

https://launchpad.net/~danielrichter2007/+archive/grub-customizer

Execute these commands one by one:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get dist-upgrade

grub customizer list

share|improve this answer
    
Please note now I am booting from the cd-rom and trying to edit /etc/default/grub on the disk. This is because I cannot skip memtest, and even it's done, the system still boot into memtest. Can I install the software you said? –  chenwj Oct 5 '12 at 8:27
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.