Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.04 Server. After my first login, I saw the IP and it is dynamic (I guess). I tried to change it by sudo vi /etc/network/interface but this file is blank.

Can anyone help here?

share|improve this question

3 Answers 3

You typed: sudo vi /etc/network/interface

You should have typed: sudo vi /etc/network/interfaces

<<<< you forgot the S >>>>

share|improve this answer

Ubuntu uses "Network Manager" to manage the network configuration.

run nm-connection-editor to set static-ip.

share|improve this answer

Adapted from: Create a Static IP from the Command Line


Basically, steps needed are:

Find out you current settings:

ifconfig eth0

Edit /etc/network/interfaces to meet your requirements.

Look for these two line:

auto eth0
iface eth0 inet dhcp

Change them to instead be: (example IP addresses)

auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
    address 192.168.0.130
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1

Then re-start your server.

It should now be using: 192.168.0.130

share|improve this answer
2  
12.04 also needs dns-nameservers 192.168.0.x as they changed how resolv.conf works. –  charlesbridge Oct 5 '12 at 11:11
    
Sorry, I cribbed from my old notes for 10.04 LTS server. –  david6 Oct 5 '12 at 12:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.