Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I log in the sound is muted. Why is that?

enter image description here

This image is from the Xfce mixer, while the lxde volume does not show that the sound is off.

So, I can see the sound muted only in Xfce Mixer. But I can also start the sound in another application, Pulse Audio Volume Control, if I change a setting in Output Devices from Analog Mono Output to LFE on Mono Separate Devices:

enter image description here

enter image description here

The Analog Mono Output option here sets in fact the Xfce Mixer in the mute position from the first image.

Could this be related to managing sessions (and therefore to these question)?

This happens in LXDE session as well as in Lubuntu session. Starting sound and logging out and in between any of these two sessions would mute the volume as shown. Starting the volume in one of these and logging out and then logging in into the Gnome session, the sound would be off; but then, after starting sound, logging out of Gnome and then logging in into any session, the sound would not be muted. But after restart it would be so no matter the session.

share|improve this question
up vote 2 down vote accepted

This must not have to do with pulse audio, rather, with ALSA (the linux sound driver).

Try configuring the ALSA driver with this command: amixer sset Master unmute or if that don't work, fire up a terminal and type alsamixer which uses an ncurses gui to configure.

After you have done any configurations, type in the terminal alsactl store and be sure to add the ALSA daemon in your init configuration files.

If you would need more information, you could find it here. It's very accurate, but be careful with the part about the init config files because Arch uses different config files to my knowledge than Debian.

share|improve this answer
thnx. i had added some info before seeing your answer. is the answer exactly the same now? as it seems that this does has something to do with the Pulse Audio Volume Control – cipricus Oct 5 '12 at 12:36
@cipricus Well, you can try it, and see if it helps you. – NlightNFotis Oct 5 '12 at 12:36
yes, amixer sset Master unmute worked. and then i fired alsactl store in root, which allows me to keep using the xfce mixer settings as before and not to change them as in my answer posted here – cipricus Oct 5 '12 at 13:03

As seen in the first image in the question, the Xfce Mixer has a setting concerning the sound card. Changing that as below solved the problem.

enter image description here

I had installed the Xfce mixer for its advanced options, but these are not available for the option showed here: the microphone settings are not available in this way, which might be a problem. So, I'll prefer as final the other answer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.