Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Caps Lock key on my keyboard is not working.

The light indicator does not come on and nothing is capitalized when typing.

What do i need to do to fix this issue.

xmodmap -e "add Lock = Caps_Lock" did not work.

Swapped out other keyboards and still have the same results. The Caps Lock is working on all three on windows.

share|improve this question

closed as too localized by Tom Brossman, Jorge Castro, Stephen Myall, Amith KK, LnxSlck Oct 5 '12 at 11:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to AskUbuntu. Are you sure its not hardware issue? –  penreturns Oct 4 '12 at 18:32
    
Swapped out for 2 other keyboards and all have the same result. –  prolink007 Oct 4 '12 at 18:38
    
Only Caps Lock? Have you check others? –  penreturns Oct 4 '12 at 18:39
    
All other keys appear to be working besides Caps Lock and Scroll Lock. I do not care about Scroll Lock but Caps Lock is killing me. –  prolink007 Oct 4 '12 at 18:43
1  
It seems to me that we should actually not close this as too localized, because there are situations outside this very narrow one (of being intentionally pranked) where unexpected settings in keyboard layout options could cause this problem. (For example, someone could have forgotten setting it themselves, or they may have gotten the computer from someone else who modified that setting.) The answer here may be helpful to more people; I think this question should remain open. –  Eliah Kagan Oct 5 '12 at 0:43

1 Answer 1

LAWL. I got pranked. =/

A co-worker disabled my scroll lock when using my computer the other day. He changed my Keyboard layout options under keyboard layout to make my Ctrl key to act as my Caps Lock.

Got to Settings -> Keyboard Layout -> Options.

There was a Ctrl key position and he had Caps Lock as Ctrl selected.

Hope this helps someone else.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.