Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to fix “The system is running in low-graphics mode” error?

I am totally new to Linux, and Ubuntu.

I bought ASUS X53E Notebook, erased Windows and installed Ubuntu. First it worked ok.

Then when I started working with it, i opened the terminal, entered sudo chmod 666 usr and then all the icons from the main panel disappeared + the whole system stopped responding.

I decided to restart the system. When restarted, a message appears:

the system is running in low graphics mode

and below it:

Your screen, graphics card and input device setting could not be detected correctly. You will need to configure it yourself.

But the "OK" button is disabled and if I press any buttons nothing happens.

If I enter Ctrl-Alt-F2 it opens the bash terminal. But there commands sudo or apt-get are not found and it says that permission denied if i try to enter any folder like cd /usr

If I enter the su command it asks for the password I don't know.

When encountering this problem first, I reinstalled the whole Ubuntu. but today it happened again just the same.

What shall I do? maybe there is something wrong with the hardware? If I need to install another distribution of Linux could you recommend one? but I'd rather stick to Debian releases like Ubuntu. so how do I fix the problem?

PS: Please give answers in simple terms because am a newbie so i don't know what goes where yet.

share|improve this question
1  
What was your intention in doing so? –  cauon Oct 4 '12 at 14:47
    
I thought that my programs should be installed in that directory. Which directory is usually used to install AMP part of LAMP, java and other applications? –  John Oct 4 '12 at 16:23
    
To get an idea on what belongs where I'd recommend checking the filesystem documentation. –  cauon Oct 4 '12 at 16:28
1  
Just check the answer of @Anwar. You removed the execution rights in the folder. With no execution rights the applications aren't allowed to run at all. This will corrupt the functionality of your system. –  cauon Oct 4 '12 at 17:33
1  
:) you are welcome. Now I see what you wanted to do! Note: you can edit rights more safely with the +x +r +w options for chmod. For the start they are much more easy to use. –  cauon Oct 4 '12 at 17:40
show 3 more comments

marked as duplicate by jokerdino, devav2, Stephen Myall, Mik, Minato Namikaze Oct 19 '12 at 12:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 5 down vote accepted

You have just corrupted the permission settings of important system files. You won't be able to use the system normally.

By using 666 as permission settings, you successfully removed the execution bit from the program and as a general sense you should not be executing any program in /usr/ directory. And as far as I know, the unity program resides in /usr/bin directory which is of course failing to execute.

The only option is reinstalling Ubuntu again. And please don't chmod the system files without knowing exactly what you were doing.

Check these links:

The last link will give you information about the system files and folders

share|improve this answer
    
Could you please specify which directories are the ones never to change permissions? –  John Oct 4 '12 at 16:24
    
I didn't say you should never change permission. but You should be knowing it before doing. The directories are: all directories without your home . That is /usr/ /bin`, /sbin and such. It is generally ok to change permission in /home/your-username-here directories, since those are your files –  Anwar Shah Oct 4 '12 at 16:28
    
@ArtemMoskalev you can check the last link, it will give you indication about the system folders –  Anwar Shah Oct 4 '12 at 16:39
    
aha..i really appreciate! thanks) –  John Oct 4 '12 at 17:37
    
@ArtemMoskalev Can you consider accepting the answer? Glad that it helped –  Anwar Shah Oct 4 '12 at 17:42
add comment

After reboot try Ctrl+Alt+F1 or Ctrl+Alt+F2.

Log into console and try sudo chmod 755 /usr.

share|improve this answer
    
@Anwar, i've looked at my own filesystem about /usr. And i know that chmod without -R key does not affects on "everything under". So... let's repair /usr because "everything under" is not broken. –  martini Oct 4 '12 at 18:50
    
I cant see recursion in text showed. –  martini Oct 5 '12 at 6:15
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.