Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my ubuntu 12.04, the graphviz is not the latest version(2.29). I need some features available in the latest version of graphviz. I tried to install the graphviz version 2.29, which requires libgraphviz4(>=2.18). I anyhow installed libgraphviz4 and installed graphviz 2.29. For that I have to remove packages libcdt4 and libpathplan4.

Now whenever I try to generate graph, I get some problems: For e.g.:

dot -Kfdp -n -Tpng -o samplePOS.png forcePOS.dot

It says:

dot: error while loading shared libraries: libgvc.so.6: cannot open
shared object file: No such file or directory

neato -Tps -o sample_1.ps sourcedot.gv

It says:

neato: error while loading shared libraries: libgvc.so.6: cannot open
shared object file: No such file or directory

So, I am looking for some ways so that I can run graphviz 2.29 in my ubuntu 12.04.

share|improve this question

2 Answers 2

up vote 6 down vote accepted

First a warning for using PPA (mainly unstable)

The below PPA: ppa:dperry/ppa-graphviz-test is an unstable PPA. So, you are given warning.

Use this commands in a terminal to install the unstable 2.29 version of graphviz.

sudo apt-add-repository ppa:dperry/ppa-graphviz-test
sudo apt-get update
sudo apt-get autoremove graphviz
sudo apt-get install graphviz

If you get this error "graphviz : Depends: libgraphviz4 (>= 2.18) but it is not going to be installed", run the following

sudo apt-get remove libcdt4
sudo apt-get remove libpathplan4
sudo apt-get install graphviz
share|improve this answer
    
I followed these steps But it is not able to install the latest graphviz version. I encountered the same problem which I have stated in the beginning, i.e. requires libgraphviz4(>=2.18) imageshack.us/f/17/screenshotfrom201210041.png –  bidur Oct 4 '12 at 7:20
    
If you have previous installation of graphviz, remove it completely –  Anwar Shah Oct 4 '12 at 7:25
    
Thank You very much. I could install graphviz 2.29 after removing packages libcdt4 and libpathplan4. –  bidur Oct 4 '12 at 7:33
    
Can you accept the answer then, since it may help future visitor. thanks –  Anwar Shah Oct 4 '12 at 7:34
    
This installs 2.26.3 again for me. Any idea why? –  KomodoDave Oct 7 '12 at 18:32

Since you mess with some libraries i advice you to remove graphviz and install again

sudo apt-get remove graphviz
sudo apt-get remove graphviz-dev
sudo apt-get remove graphviz-doc
sudo apt-get install graphviz

This is a same situation for other user

share|improve this answer
    
I tried this but this will install graphviz (2.26.3-10ubuntu1) NOT the latest version 2.29 –  bidur Oct 4 '12 at 6:34
    
But 2.29 still not stable. I advice you to stay at 2.26.3 as Ubuntu propose to avoid such conflicts –  user61928 Oct 4 '12 at 6:37
    
even I wish to stay with the stable version but I need some features provided by the version 2.29 –  bidur Oct 4 '12 at 7:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.