Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I bought the Humble Indie Bundle VI containing Torchlight (among others) and installed them via the software centre. A few days later some updates were available in the Update Manager as in this picture.
Screenshot showing update
Unfortunately, when trying to install it, the following message appears:
Error message
Which reads as follows:

(Reading database ... 425427 files and directories currently installed.)
Preparing to replace torchlight 1.0+2012+09+18a-0ubuntu1 (using .../torchlight_1.0+2012+09+26-0ubuntu1_i386.deb) ...
Unpacking replacement torchlight ...
dpkg: error processing /var/cache/apt/archives/torchlight_1.0+2012+09+26-0ubuntu1_i386.deb (--unpack):
trying to overwrite '/opt/torchlight/Torchlight.png', which is also in package torchlight-bin 1.0+2012+09+18a-0ubuntu1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:

Could anyone help me fix this?

share|improve this question
Clean your apt cache then try again. – Uri Herrera Oct 3 '12 at 22:55
I have, it still isn't working. (Well, I ran apt-get clean) – captainjamie Oct 4 '12 at 17:30
up vote 3 down vote accepted

I was having this problem as well. I installed it from the command line by running sudo aptitude safe-upgrade and it installed successfully.

share|improve this answer
Thanks, that worked, after running. I had to run apt-get clean first. – captainjamie Oct 5 '12 at 9:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.