Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded Avast using terminal command wget http://files.avast.com/files/linux/avast4workstation_1.3.0-2_i386.deb and the download and installation was successful.
Then I chose check updates(database) from the interface. As soon as the updates were downloaded the following problem started.

An error occurred in avast! engine: Invalid argument

What should I do to correct the problem?

share|improve this question

2 Answers 2

This is a known problem in Avast. You need to increase the maximum amount of shared memory allowed.

  • To load it without rebooting sudo sysctl -w kernel.shmmax=128000000
  • To make it permanent, edit the file /etc/sysctl.conf (gksudo gedit /etc/sysctl.conf), and add this line to the end of the file kernel.shmmax = 128000000
share|improve this answer
    
thank you. I used the first option and I have managed to get it to work. the second option, i don't know how to carry it out. what should i do to carry it out? –  Sizwamulena Kabila Oct 3 '12 at 21:54
    
There, I changed the program nano to gedit, so you can edit graphically. –  Sepero Oct 3 '12 at 22:29
1  
This didn't work for me but using 256... worked instead. –  pbhj Jun 11 at 0:12

I use Puppy Linux Slacko and this solution worked for me.

I've a 4GB memory. So this solution, I guess will work for computers with higher memory not low ones.

Insert

SHMMAX=`sysctl -n kernel.shmmax`
[ $SHMMAX -lt 128000000 ] && sysctl -w kernel.shmmax=128000000

in /usr/lib/avast4workstation/bin/wrapper-script.sh

Then Open terminal and type

sysctl -w kernel.shmmax=200000000

Hit Enter.

And then start avast. Now Avast works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.