Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to a IM account (WebEx connect - Protocol: Jabber/xmpp) with Thunderbird 15 but it fails to connect. It doesn't throw any error just says "Not Connected".

Pidgin works perfectly with the same setting what I provided in Thunderbird 15.

So the question is

  1. Will Thunderbird chat account(xmpp) support libnss3
  2. Do I debug and collect info, when Thunderbird tries to connect to a chat account?

I'm on Ubuntu 12.04

share|improve this question
1  
May be of help: getsatisfaction.com/mozilla_messaging/topics/… –  unor Oct 4 '12 at 14:10
    
@unor Thank you very much. Wonderful that helped me to fix it. –  devav2 Oct 4 '12 at 16:12

3 Answers 3

up vote 3 down vote accepted

The link shared by unor helped me to fix this issue.

The IM account was unable to connect due to certificate issue. Though I have a valid certificate it wasn't able to verify the certificate.

Here is the detailed steps on how to fix the issue.

Get the proper certificates

  1. Get the certificate (If you dont have one) from pidgin account.

    • open Tools -> Certificates
    • select the appropriate hostname and click "Save" (file: certificate.pem)
  2. Open Thunderbird -> Edit -> Preference -> Advanced

    • choose Certificates tab -> View Certificates
    • Select Servers and Click Import to add the download "Certificate.pem" and save it.

or

  1. Use this link https://kingant.net/check_xmpp_dns/ to get proper server details.

    • open the link and enter "yourdomain.com" to fetch the server details enter image description here
    • Copy the Target value in "Client records for yourdomain.com". In this case it is c2s.webex.com.webexconnect.com
  2. Open Thunderbird -> Edit -> Preference -> Advanced

    • choose Certificates tab -> View Certificates
    • Select Servers
    • Click on "Add Exception..."

    • Enter the copied text under "Server Location:" with :5222 at the end (Replace https:// with c2s.webex.com.webexconnect.com:5222)

    • Click on "Get Certificate" and remember to tick "Permanently Store this exception" and save the setting by clicking on "Confirm Security Exception"

Adding XMPP account

  1. Open Thunderbird -> Edit -> Account Settings
  2. Add Chat Account
    • select xmpp
    • username: [email protected]
    • password: .......
    • Resource: Doesn't really matter
    • Server: im.domain.com or the text grabbed from the URL(c2s.webex.com.webexconnect.com)
    • Port : 5222

Now we are good to go :)

share|improve this answer

As per your step.

Adding XMPP account
Open Thunderbird -> Edit -> Account Settings
Add Chat Account
select xmpp
username: [email protected]
password: .......
Resource: Doesn't really matter
Server: im.domain.com or the text grabbed from this URL c2s.webex.com.webexconnect.com

share|improve this answer

Well, the certificate exception did seem work from Tbird to Openfire -- I then had a new error "Not authorized (Did you enter the wrong password?)" so still stuck.

I then change the username (from format "abc" to "abc@server") and that corrected the issue. Some clients want username, some want user@server.

My 2 cents worth to help those that found this issue.

share|improve this answer
    
Welcome to Ask Ubuntu! Please don't add comments as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, or to add actual comments when seeking clarification of any issues. If you have a new question please ask it. –  Braiam Aug 20 '13 at 21:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.