Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a Lexicon Alpha usb audio interface, but it's not showing up as a usb device or as a sound card.

share|improve this question
1  
Please add a tiny bit more detail to your question: what Ubuntu release are you using, how do you know it is not being detected by the system? Can you give us some logs? –  Bruno Pereira Oct 3 '12 at 19:38
1  
My Lexicon shows up as just "Digitech" under lsusb and has more correct info in the listing from usb-devices. However, it does not appear to show up when running sudo lshw in the terminal. It also shows up in System Settings->Sound, and in pavucontrol, as well as being usable by JACK. –  dobey Oct 3 '12 at 19:54
    
[solved] I removed pluseaudio and used the alsa hw:2,0 ; works great now. Sorry for leaving the question open. –  Syborgia Alphas Mar 13 at 22:48
    
BTW - for musicians, (from what I've read and tried) it's best if pulseaudio is removed. –  Syborgia Alphas Mar 13 at 22:49
add comment

1 Answer

Try unplugging the USB cable and plugging it back in. This might trigger detection.

I have Lexicon Alpha with Kubuntu system (and Win7 dual boot). Linux and Windows does not detect the stupid sound card on login, I must manually unplug the USB cable and plug it again to detect the card, everytime!

share|improve this answer
    
for some reason it battles with the primary sound card for hw:0,0 when you boot. Unplugging at every shutdown/restart and plugging in after reboot (after everything loads) is a must. –  Syborgia Alphas Mar 13 at 22:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.