Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Mini 1012 which has an Intel N450 processor and GMA 3150 integrated graphics card running Ubuntu 10.10. According to Intel's website the graphics card supports OpenGL 2.0.

http://software.intel.com/en-us/articles/quick-reference-guide-to-intel-integrated-graphics/#9

But when I type glxinfo in terminal the OpenGL version string gives me the following

OpenGL version string: 1.4 Mesa 7.9-devel

I have installed the latest drivers but it didn't work. So, how can I enable OpenGL 2.0 on this card?

share|improve this question

2 Answers 2

up vote 8 down vote accepted
  1. Install driconf from the software center .

  2. Press Alt + F2 and type driconf and press enter .

  3. Change Enable limited ARB_fragment_shader support on 915/945 from No to Yes by clicking on the button next to it

share|improve this answer
    
This might solve a problem i was having with 2 dv6700 laptops. –  Luis Alvarado May 3 '11 at 23:58

Ubuntu 10.10 should contain the drivers for the GMA 3150. This seems a slightly odd situation, with the Intel website saying:

Intel® Graphics Media Accelerator 3150 supports OpenGL* 1.5 with Microsoft* Windows* and OpenGL* 2.0 with Linux*

I would suggest you report a bug, by pressing Alt+F2 and entering ubuntu-bug xserver-xorg-video-intel. This will automatically attach information about your hardware setup to the bug report. This way the Ubuntu graphics team will get to see your problem and help you solve it.

share|improve this answer
    
thank you very much.... posted the bug –  mahmoudelbadry Jan 1 '11 at 10:17
    
    
yes this is the bug i reported............do please subscribe if you're having the same problem –  mahmoudelbadry Jan 4 '11 at 9:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.