Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing problems when opening some videos and contents from some web sites. I figured out that Adobe Flash Player is not working properly in my system. I have installed a fresh copy of 12.04 on 64bit machine.

I have executed these commands:

sudo apt-get update
sudo apt-get install flashplugin-installer
sudo apt-get install ubuntu-restricted-extras

But still, the problem persisted.

I will be very thankful for any help.

share|improve this question
    
which browser are you using? –  Alen Oct 3 '12 at 16:50
2  
Think he's using firefox by the question's tags –  Evandro Silva Oct 3 '12 at 16:51
    
See my answer for a similar question:askubuntu.com/a/184031/58990 –  IgnitE Oct 3 '12 at 17:04

8 Answers 8

Try Flash-Aid. It's a nice little script in the form of an extension to Firefox that will fix conflicts and install the correct version of Flash for your system, as well as the Firefox Flash extension.

I haven't used it 12.04 (since I haven't had any issues with Flash), but I have used it in previous versions and it worked great.

Just install, then run the extension (if it doesn't start when you start Firefox, it should show up in the tools menu), and follow the steps in the wizard. Once it's done, you can remove the extension if you want.

share|improve this answer
1  
Flash-Aid doesn't look available anymore. Page addons.mozilla.org/en-us/firefox/addon/flash-aid reads "This add-on has been removed by its author." –  Waldir Leoncio Mar 4 at 19:09

Install Xubuntu restricted extras from ubutu software centre.OR try usinng command

  1. CTRL + ALT + T
  2. sudo apt-get install xubuntu-restricted-extras now press enter
  3. go to software centre and add add-ons from ubuntu software centre.It worked for me.
share|improve this answer

... as an extension to the answer referring to the Flash-Aid tool, I can say that my firefox/flash-problem was solved by applying the older flash-plugin from adobe-flashplugin 10.2.159.1-0hardy1 source package in Ubuntu.

Flash-Aid gives the opportunity to install your "custom" xxx.tar.gz: so download and try out the plugin of the above mentioned package Hardy Heron of Ubuntu.

Good luck!

share|improve this answer

Download: http://get.adobe.com/flashplayer/tar.gz file. Extract it and copy the libflashplayer.so file to /usr/lib/firefox/plugins using root. That is it.

To copy the file using root, use command gksu nautilus, provide your root password and navigate to the location indicated above.

share|improve this answer
    
Using root? Could you explain how to do that? –  Navigatron Apr 1 '13 at 23:13

I came across these commands and after installing, my problem miraculously solved and I have been watching all Youtube videos without any problem.

If you really want to run Flash videos in Ubuntu 12.04 64 bit. only these commands work in Ubuntu 12.04 64 bit.

sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin
share|improve this answer

In case you are using Firefox try whether Flash is working if you open Firefox by sudo firefox. If so, sudo dpkg-reconfigure firefox might fix your problem.

share|improve this answer

None of these steps above worked for me. I got flash finally working in my Firefox on 12.04 (flash stopped working after I updated Firefox to latest version recently (December 2013)).

So, it case it helps anyone, I finally got flash working again by using an older version of adobe flash (10.3.183.75). I simply installed the libflashplayer.so file in

/usr/lib/mozilla/plugins 

The file to download from

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

is

"(Released 4/9/2013) Flash Player 10.3.183.75 (61.21 MB)"

(others might work, I tried this one first and it worked so I didn't try any others).

Once you unzip the archive:

If there is a link already existing in /usr/lib/mozilla/plugins to a different libflashplayer.so then delete it first.

Then run these commands

unzip fp_10.3.183.75_archive.zip

cd fp_10.3.183.75_archive/10_3_r183_75

tar -xzvf flashplayer_10_3r183_75_linux.tar.gz

sudo cp -p libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so

And now my flash is working in Firefox for youtube videos, etc.

HTH, Gil

share|improve this answer

Apart form Gil's instructions above, I additionally needed to:

sudo cp -p libflashplayer.so /usr/lib/flashplugin-installer

Where "libflashplayer.so" is the old version from the fp_10.3.183.75 archive mentioned in Gil's above message.

This made Flash Player work in 12.04 for me. Be aware that Ubuntu's Update Manager suggests replacing the fp_10.3.183.7 version with a new version. So, uncheck Flash Player updates in the Update Manager.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.