Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sometimes(rather many times), when I shutdown using the menu option >> Shutdown, the system hangs at a Purple screen with dots. I have waited for 10 mins, but then it becomes clear that i need to do a hard shutdown using power button.

I am using Ubuntu 64 bit AMD edition(12.04.1 LTS) on HP Proliant Microserver(N40L) with OEM hardware.

share|improve this question
What ubuntu version are you using? – Evandro Silva Oct 3 '12 at 15:57
Ia m using 12.04.1 LTS – vikas112 Oct 3 '12 at 15:59
updated original post – vikas112 Oct 3 '12 at 16:01
up vote 1 down vote accepted

From what I know, there is a bug with some graphic cards you can check here, I've tryed kubahaha's way and it worked for me:

Type in terminal:

  1. sudo gedit /etc/default/grub
  2. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  3. Change it to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
  4. Save and close the file.
  5. Finally, in terminal: sudo update-grub

Similar questions with this bug:

share|improve this answer
ok, I will try it out and report my result here. – vikas112 Oct 3 '12 at 16:08

Also, have you tried to see what happens when you press F8 when the purple screen appears? You will be able to see where it hangs.

Edit: this can be made into a comment if someone wishes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.