Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Sony VAIO that originally had Windows 7 installed on it but I decided to format and install 12.04. After spilling water on it, I didn't turn it off right away and a minute later the screen went black so I turned off and on again and it said

Operating System Not Found

I left it overnight disassembled to dry. I turn it on today and it works. About 2 minutes after boot, screen stops responding and I have to manually turn it off, gives me the same OS not found error.

So I booted the LiveCD I had for Ubuntu and connected to the Internet and installed then tried using the boot-repair application to fix it. Gave me the message no operating system found too.

How to access my data and OS?

share|improve this question
up vote 0 down vote accepted

It seems like your hard drive might have been damaged by some of the water. This could have messed with the main boot files in Ubuntu to the point where they are unrecognisable/recoverable.

Try booting up with the live CD, and see of you can access your documents etc. from your hard drive, and then back them all up (to a portable hard drive or flash drive) and do a fresh install. This will prevent any future corruption issues (hopefully) and allow you to boot into a fresh system with which you can restore your backed up data.

Probably not what you wanted to hear, but I hope it helps.

share|improve this answer
Thanks for the answer. However, I wasn't able to locate my HDD or any of my files when booting from LiveCD, I tried a few methods, any thoughts on that? – Fishies Oct 3 '12 at 17:58

You may want to try TestDisk, which is a tool to recover documents on damaged disks.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.