Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't disable showing drive's icons in Launcher bar. I have looked for that option both in CCSM (it used to be in Experimental tab) and in dconf-editor (desktop->unity) and it is missing.

Drive icons in the launcher

How can I remove launcher drive icons?

share|improve this question
add comment

4 Answers

(For Ubuntu 11.10 and 12.04)

  1. Install compizconfig-settings-managerInstall compizconfig-settings-manager if you haven't already.
  2. Run CompizConfig Settings Manager and navigate to the Unity plugin.
  3. In the Experimental Tab, change the Show Devices combobox to Never.

    enter image description here

share|improve this answer
6  
The option is missing from ccsm in Ubuntu 12.10. It's not in Ubuntu Tweak 0.8.2 either. –  Bucic Nov 21 '12 at 17:53
add comment

Install MyUnity by using sudo apt-get install myunity, then run MyUnity from dash and in the Launcher section, select Never from Show Devices Drop Down menu, That's it!

share|improve this answer
1  
I actually followed the answer from Jakob's link, but I guess this would work as well. –  Benno May 21 '12 at 12:23
    
Ubuntu 13.10 seem to not have myunity in common repos, where will i find it? –  decebal Jan 9 at 7:57
add comment

(For Ubuntu 12.10)

You are right that there used to be a setting in CCSM to configure the behaviour of mounts appearing in the launcher but that option has been removed in 12.10 at the moment. I can't confirm whether it will be added back again before it is released to the public. See bug report #1053704.

Currently, you only have two options: Either to show the mount drives on the launcher or to blacklist it from the launcher. You can't configure the setting depending on whether they are actually mounted or not.

So, if you want to remove it from the launcher, the only option you have is to blacklist it from the launcher.

Blacklisting it from the launcher is actually very simple. Right-click on the mount and select Unlock from Launcher.

Remove mount from launcher

Do remember that blacklisting it from launcher means you will never see it again in the future even if you mount it unless you reset the settings.


You can also blacklist the mounts using dconf-editor or gsettings command but that requires you know the UUIDs of the mounts.

If you are using dconf-editor, scroll down to comcanonicalUnitydevices and enter the UUID of the mount in blacklist.

Dconf-editor

If you want to use gsettings, you can use a command of this format:

gsettings set com.canonical.Unity.Devices blacklist "['UUID of your mount']"

Just use the UUID of your mount inside the square bracket and the single quote marks.

If you are not sure of the UUID of your mount, you can use this command:

sudo blkid -o list

It will display the partition number, their label (if any) with their UUID.


Now, if you want to reset the settings, run this command in a terminal:

gsettings reset com.canonical.Unity.Devices blacklist
share|improve this answer
3  
What about usb drives, phones, cameras ? They're constantly keeps showing in the launcher every time I connect them. I don't need this? –  Yuriy Voziy Nov 30 '12 at 10:56
2  
Blacklisting might be OK for permanently attached storage, but USB drives etc still appear. I want as permanent solution to this problem for all types of drive and for installed programs would be nice too. –  Andrew Dec 17 '12 at 8:13
    
@AndrewHeath is correct, this doesn't work on USB storage drives and devices, every time they are plugged in, all the partitions and volumes icons are still automatically displayed on the launcher. –  Peachy Jan 2 '13 at 7:01
    
Also doesn't work on CDs that are inserted. This is making me crazy! –  HDave Jan 23 '13 at 18:01
    
I've created a launchpad issue for this -- please vote it up. bugs.launchpad.net/ubuntu/+source/launcher/+bug/1103593 –  HDave Jan 23 '13 at 18:08
show 2 more comments

Open dconf-editor: Hit Alt+F2, type dconf-editor and hit Enter.

In dconf-editor goto: comcanonicalunitydevices.

You will see blacklist with key ['UUID-Label']. Add your UUID and devices-Label in it.

share|improve this answer
1  
The following answer goes more into detail: askubuntu.com/questions/195988/… –  LiveWireBT Oct 28 '12 at 0:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.