Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed VMware Player 5.0.0 today and Ubuntu 12.04.1

Ubuntu cannot see the Windows drives or external drive. I am using Windows 7 64 bit - do I need to use Ubuntu 64 bit also?

share|improve this question
    
In the options tab of the virtual machine settings there is an options to enable shared folders. You can also add devices. –  chris Dec 7 '13 at 4:08
add comment

2 Answers

That's rather the way virtualization works. When you define your virtual machine you define what it is and what data it can see. When you run that machine it can't do anything outside of what you have defined.

This is a reason virtualization is often used for testing or "sandboxing" -- it can control both innocent and malicious program errors from destroying important data.

I believe that one can define additional disk resources for vmplayer by defining and using .vmx files that point to additional file strorage for the virtual machine; and that there is a wizard for defining such additional hardware. I don't know about the availability of these features.

Ubuntu also has includes a virtual-manager and qemu-kvm which can be used to define virtual machines and what they contain.

share|improve this answer
add comment

If I understand you correctly, you have made a virtual machine using VMware player, and you are running Ubuntu 12.04.1 on this virtual machine.

I believe your VMware player does not see your windows drives, because as far as the virtual machine is concerned, the windows drives are running on another machine. You would have to access your windows drives as drives you access over the network, or follow the information in how-do-i-access-the-hosts-hard-drive-in-vmware.

share|improve this answer
    
Thanks to John & Gertigan. I looked into VMware player options and you can specify which drives & folders are visible - access had been disabled so i thought this was the problem. After starting up VMware player and Ubuntu 64 bit there was no change. I do get errors when starting up - can't see floppy or IDE drive so maybe it is some issue with drivers ? I get an error trying to browse the windows network and get the error unable to mount location. I have IP connectivity & can log onto servers in our network and browese web, get email etc. –  Robert Oct 5 '12 at 8:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.