Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using 12.04 and in my work we connect to a Citrix XenDesktop. I've installed Citrix Receiver, using this link and it all works perfectly.

But, I have a problem. Alt+Tab doesn't work in full screen mode. There are several adjustments you can choose when login in, with the Settings "button" up in the right corner. (Sorry, I couldn't post an image because I'm new.)

I like to work with 95% full screen, with the windows key combination in "full screen mode only". This allows me to use the windows combinations when a work in full screen, inside the remote computer (inside Citrix).

I can Alt+Tab past the "Citrix computer" when I put it down to 95%. It also allows me to use the "Ubuntu menu" on the left side. But I really can't make this work in Ubuntu.

I've tried to put the windows key combination to "remote server only" and yes, it works inside the server, but also only there and the Ubuntu menu stops working. (in example print Screen. I am using this for documentation.)

When I try to Tab from one place to another, even when Citrix isn't in full mode, if I stop there and the continue "tabbing" it continues inside Citrix.

I want to use windows key combination, but only in full screen mode. Does anyone have a solution to fix in another way?

share|improve this question
up vote 2 down vote accepted

Finally it's now working. I'm actually accessing remote desktop through web browser Google Chrome on Ubuntu 12.04.

I changed all the setting in Citrix receiver, but didn't realize to change the setting on web page. That is, after typing username/password for the remote URI in the browser, there is a tab called setting (before click Remote Desktop Connect on AmericasXA...).

I was able to change the window size to full screen from Seamless. That's it, Alt+Tab and other keys started working fine on the remote desktop.

share|improve this answer

I can't test it, but one likely possibility is that the HUD is grabbing the Alt key.

Please check this answer, set the HUD key to another one and check if it helps.

share|improve this answer
    
Hi. Thanks for the tip, but this didn't solve my problem. It seems like Ubuntu don't understand that Citrix is in full window mode. – porec Oct 4 '12 at 6:07
    
Perhaps I am doing i wrong? I just click on the maximize button, or doubleclick the top of the window to maximize or back to "normal size". – porec Oct 4 '12 at 6:37
    
It seems that Ubuntu understands the Citrix window just "like another maximized screen. – porec Oct 4 '12 at 6:43

changing DesiredHRES, DesiredVRES values in All_Regions.ini file worked for me

  1. search for file named All_Regions.ini in the ica client installation dir/config and open it with sudo access (on ubuntu 13.04 the file is at this location /etc/icaclient/config/All_Regions.ini)

  2. Scroll down to the [Virtual Channels\Thinwire Graphics] section.

  3. Modify the DesiredHRES=* and DesiredVRES=* to

    DesiredHRES=1024
    DesiredVRES=768
    
  4. Save the file and proceed to launch your XenDesktop session.

Ref: http://support.citrix.com/article/CTX128845

share|improve this answer
1  
This worked for me (icaclient from Firefox on Ubuntu 13.10), but the setting I changed was UseFullScreen=false in the same file. Changing the screen dimensions didn't work for me. Using the ICA client settings panel also didn't work. – dirkjot Apr 14 '14 at 10:36

Just use Ctrl+Alt+Del, it always works.

share|improve this answer
    
Welcome to Ask Ubuntu! I recommend editing your answer to explain what this does. – Eliah Kagan Dec 19 '12 at 1:21
1  
... and it will only work when the it is enabled under 'keyboard shortcuts' – fabricator4 Dec 19 '12 at 3:33

ENABLE ALT+TAB APPLICATION TOGGLING IN A CITRIX XENAPP DESKTOP SESSION

Open regedit on the client device to edit the registry Navigate to the key HKEY_LOCAL_MACHINE \SOFTWARE\Citrix\ICAClient\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard\ Open Key: TransparentKeyPassthrough Set the value to: Remote

Exit the Citrix receiver if it is started and log back into your Citrix desktop. When the Citrix desktop session is the Active window, you will be able to toggle between the applications in that session with Alt+Tab

share|improve this answer
    
Erm, the client is an Ubuntu desktop??? There is no registry??? – dn-ʞɔɐq ɹW Jan 20 at 23:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.