Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I really need to figure out how to configure out how to get my linux box to mount a drive from my mac. They are permanently networked.

My Mac is called fuzzy, and has been set up to allow the Movies folder out via SMB. I ran smbtree and this drive shows up as \\FUZZY\Movies.

Things I have tried:

sudo mount -t smbfs \\FUZZY\Movies -o username=**,password=** /media/Movies

     Error: mount: unknown filesystem type 'smbfs'

sudo mount -t cifs \\FUZZY\Movies -o username=**,password=** /media/Movies

     Error: mount: wrong fs type, bad option, bad superblock on \FUZZYMovies,

sudo mount -t hfsplus -o force \\FUZZY\Movies /media/Movies

     mount: special device \FUZZYMovies does not exist

share|improve this question
What error messages are you getting? (Please edit your question to include this information.) – Eliah Kagan Oct 2 '12 at 22:29
Hi, thanks for the quick response. I have included that information now. – Mild Fuzz Oct 2 '12 at 22:37

Use slashes (/) instead of backslashes (\).

mount will accept slashes, and the problem with backslashes, even if they are accepted, is that a backslash is also a shell escape character. If you want the mount command to see \\, you would have to put \\\\ on the command line.

So name the host-and-share you want to mount like this:


With just that change, your mount commands (except the -t hfsplus one) should be correct. But I recommend writing your Samba mounting commands in a more ordinary fashion, like this:

sudo smbmount //FUZZY/Movies /media/Movies -o username=**,password=**

Thanks to Braiam for correcting a serious error in this command.

(Make sure /media/Movies exists and is empty.)

Even better, if you're invoking this manually anyway, leave off the ,password=** part; it will prompt you for the password and you can enter it, and then the password won't go into your command history (thus becoming visible in cleartext).

share|improve this answer
I'm getting mount error(22): Invalid argument now. – Mild Fuzz Oct 3 '12 at 5:39
@MildFuzz Does it work if you use sudo smbmount //FUZZY/Movies /media/Movies - user=** instead? (And of course ** is replaced by your actual username.) – Eliah Kagan Oct 3 '12 at 5:41
Same error I am afraid – Mild Fuzz Oct 3 '12 at 6:01
There shouldn't be using two -o switches. sudo smbmount //FUZZY/Movies /media/Movies -ouser=**,pass=** or sudo mount -t cifs //FUZZY/Movies /media/Movies -ouser=**,pass=** – Braiam Aug 17 '13 at 19:37
@Braiam You're right; using -o twice doesn't work, or if it did (since I seem to remember testing it before I posted this), it doesn't work reliably or on 13.04. In any case, -o twice was probably always wrong syntax. So thanks for finding and helping me fix this!! – Eliah Kagan Aug 18 '13 at 5:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.