Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a fresh install of Ubuntu 12.04x64 (ATI Radeon HD4770 with open source drivers) and I am having trouble getting windows to appear on the right screen.

Yesterday I plugged in my secondary monitor and it worked perfectly out of the box, except that for some reason, compiz wants to place windows on the secondary monitor rather than the first. This is a problem because I don't use the secondary monitor 100% of the time, and I don't want windows being placed on it when it is off.

Also, it's only some windows that are getting placed there. For example, the "Edit Connections" window from the networking menu is always placed off my primary screen. There are a number of other windows that do the same. While some, like nautilus, always appear on the proper monitor.

I played around with Compiz Config Settings Manager and found that if I disable the "Place Windows" plugin, all of the windows appear on the proper monitor -- except that they are placed underneath the Unity Panel, so I have to alt-drag them out each time in order to use them.

With out without that plugin, I can't seem to get a sensible setup. The windows are supposed to appear only on the active display, but for some reason Compiz doesn't want to do that with some windows.

Does anyone know a fix for this? I'd rather not have to disable and re-enable my monitor every single time I use it...

share|improve this question

closed as off topic by Eliah Kagan, con-f-use, belacqua, Takkat, Ringtail Nov 3 '12 at 23:29

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
bugs.launchpad.net/compiz/+bug/754508 Actually this seems like it may be related... –  osarusan Oct 2 '12 at 19:10
    
If you decide that's not the same bug you're experiencing, I recommend reporting this as a new bug. –  Eliah Kagan Nov 3 '12 at 16:54

2 Answers 2

Like osarusan linked, sudo apt-get install compizconfig-settings-manager, then opening compiz' general options and setting to either prefer smaller monitor or prefer larger monitor has completely resolved the issue for me.

share|improve this answer

I'm not sure what was causing the issue, but since upgrading to 12.10 I haven't had this issue anymore.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.