Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just downloaded and successfully installed python 2.5.4 , from here Python version 2.5.4

tried to search for an IDLE for Python 2.5.4 but no success...... Is there a tutorial or anything to help me install the IDLE for Python 2.5.4

Help will be much appreciated

share|improve this question
add comment

1 Answer 1

In Ubuntu 12.04 you already have python 2.7 installed so, unless you need 2.5.4, there is no need to install it.

To install IDLE:

sudo apt-get install idle

Or you can install it from the software center searching for IDLE in the search box.

Before, you could install idle for python2.5 with:

sudo apt-get install idle-python2.5 but version 2.5 is not anymore included in Ubuntu 12.04 repo so if you can't work with version 2.7, you may have to download v2.5 manually (and dependencies) and install it manually with sudo dpkg -i path/to/package if you get a deb file or compile it.

share|improve this answer
    
I need 2.5.4 version for educational purposes, does this IDLE also work for 2.5.4?? –  Muhammad Oct 2 '12 at 16:59
    
I don't think 2.7 version will work with 2.5 python because if I remember well there are differences in TK. Edited the answer. –  laurent Oct 2 '12 at 17:47
    
I downloaded the .deb file, but when opening it the ubuntu software centre opens saying "dependency is not satisfiable : python 2.5 "....???? –  Muhammad Oct 10 '12 at 11:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.