Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My printer was working under 9.x. It is a an HP Photosmart C3100 series. When I open Admin->Printing no local printers are found.

I try to add via Other (My local choices are Serial and other). I have tried many url's - ipp://localhost:631/ipp, http://localhost/ipp, localhost, 127.0.0.1, etc... None have worked. Under the networked I have tried JetDirect, using localhost and 127.0.0.1 and port 631.

I have tried many options under IPP with different variants in the host trying to verify a printer. No luck .I tried LPD/LPR with localhost and tried the probe. no luck. I tried the cups admin via localhost:631 and that didn't work. On the old version its simply found the local printer, I might have picked the driver, I can't remember but it was the photosmart c3100 series that was working.I just can't get 10.04 to print.

share|improve this question

1 Answer 1

Firstly make sure your printer is turned on! And both the USB and power cables are securely connected.

As you are having problems I'd suggest you install the HPLIP Toolbox Install HPLIP Toolbox - this software is created by Hewlett-Packard themselves.

Once installed launch it from System->Preferences->HPLIP Toolkit. From here you should click on the green add button, and follow the instructions.

If all this still does not work then you should file a bug report. Press Alt+F2 and enter ubuntu-bug hplip. In the bug description make sure you link to this question (and link from this question to the bug).

Screenshot

share|improve this answer
    
Printer is broken. Won't work on Windows either. Sorry for the time. –  Brian Dec 31 '10 at 19:55
    
@Brian No worries. –  8128 Dec 31 '10 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.