Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to access my local data, which is exported as a samba share, as if I am a samba client. Basically, how do I correctly mount my own samba share? The following mount (device) parameters:

//localhost/SHARE_NAME
//127.0.0.1/SHARE_NAME 
//IP_OF_SAMBA_SERVER/SHARE_NAME

All result in "mount: special device <device> does not exist".

Other clients have no trouble connecting/mounting the share. gvfs/Nautilus mounting is also working just fine. Ubuntu 12.04 in use.

share|improve this question
1  
To access a samba share, don't you need to preface it with "smb:"? As-in "smb://127.0.0.1/SHARE_NAME" –  BryceAtNetwork23 Oct 2 '12 at 14:20
add comment

2 Answers 2

up vote 1 down vote accepted

Thank you for the comments and answers. Looking at the issue with fresh eyes today, it appears to be a simple mount type (-t) option issue. All of the suggested device parameters, including //HOSTNAME/SHARE_NAME, are okay when used in the following mount command:
sudo mount -t cifs -o guest //LOCALHOST/SHARE_NAME //DIRECTORY/MOUNT_POINT
As for the device name variations - it seems best practice to use 127.0.0.1 to refer to the host.

share|improve this answer
add comment

from console:

#mount -t smbfs -o username=username,"password=password" //127.0.0.1/SHARE_NAME  /mnt/tmp
share|improve this answer
    
I believe that CIFS protocol is the successor to the SMB protocol and that smbfs is now deprecated and unmaintained. Refer to mount.cifs –  Dean Oct 3 '12 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.