Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu Maverick (10.10). I've read a few threads regarding wired connection problems, but haven't found a solution yet.

The problem appears after I connect to a wireless network. When I disconnect wireless and plug in an internet cable, the wired connection is not recognized at all. Even the socket appears dead (there are no diodes flashing).

The only solution so far seems to be restarting the computer. Network Manager then tries to connect to a Wi-Fi, but the wired connection is listed and working.

I've tried sudo restart network-manager, but that doesn't solve anything. After a while, available wireless networks start appearing, but the wired still doesn't.

Any ideas? Thanks in advance.


Edit: Here is the dmesg output after switching off Wi-Fi and then plugging the internet cable.

[18200.623543] Restarting tasks ... done.
[18200.648422] video LNXVIDEO:00: Restoring backlight state
[18200.707580] sky2 0000:02:00.0: eth0: phy I/O error
[18200.707715] sky2 0000:02:00.0: eth0: phy I/O error
[18200.707819] sky2 0000:02:00.0: eth0: phy I/O error
[18200.707922] sky2 0000:02:00.0: eth0: phy I/O error
[18200.708025] sky2 0000:02:00.0: eth0: phy I/O error
[18200.708127] sky2 0000:02:00.0: eth0: phy I/O error
[18200.708229] sky2 0000:02:00.0: eth0: phy I/O error
[18200.708332] sky2 0000:02:00.0: eth0: phy I/O error
[18200.708824] sky2 0000:02:00.0: eth0: enabling interface
[18200.709587] ADDRCONF(NETDEV_UP): eth0: link is not ready
[18202.662422] EXT4-fs (sda9): re-mounted. Opts: errors=remount-ro,user_xattr,commit=0
[18203.324061] EXT4-fs (sda9): re-mounted. Opts: errors=remount-ro,user_xattr,commit=0
[18211.193137] eth1: no IPv6 routers present
[18212.844649] usb 5-1: new low speed USB device using ohci_hcd and address 5
[18213.017235] input: USB Optical Mouse as /devices/pci0000:00/0000:00:13.0/usb5/5-1/5-1:1.0/input/input16
[18213.017499] generic-usb 0003:0461:4D17.0004: input,hidraw0: USB HID v1.11 Mouse [USB Optical Mouse] on usb-0000:00:13.0-1/input0

After system restart, dmesg says this:

[   19.802126] sky2 0000:02:00.0: eth0: enabling interface
[   19.802394] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   20.812533] device eth0 entered promiscuous mode
[   21.495547] sky2 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex, flow control rx
[   21.495677] sky2 0000:02:00.0: eth0: Link is up at 100 Mbps, full duplex, flow control rx
[   21.496574] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

(in reply to Ugo) Here is what I tried:

  • install wicd (as described, adding the extra lines in /etc/network/interfaces). I connected to a wireless network, suspended the computer, resumed with the internet cable plugged in and disabled the wireless connection in wicd. The wired network still does not appear. After enabling "always show the wired network" in wicd preferences I tried to connect to the wired interface that showed up, but it failed at "getting IP address".
  • the same without adding the extra lines in /etc/network/interfaces. After enabling "always show wired" and pressing the Connect button, it gets stuck at "enabling interface". The dmesg output seems to be still the same.
  • in both cases, it behaved the same way after unplugging the network cable. The eth0 interface was not even listed in ifconfig.

Even though it once seemed to be OK, it is not. The wired interface (eth0) is listed in ifconfig, but not in wicd. Dmesg says the same as above:

...
[10156.025350] sky2 0000:02:00.0: eth0: phy I/O error
[10156.025711] sky2 0000:02:00.0: eth0: enabling interface
[10156.026463] ADDRCONF(NETDEV_UP): eth0: link is not ready

So, unfortunately, this is still not resolved.

share|improve this question
    
Can you add the last few lines of the command "dmesg" when you plug in the cable after disconnecting from the wireless? –  Ugo Oct 2 '12 at 12:51
    
It took me a while to get back at it, sorry about that. I have included the dmesg output in my original post. Thank you for your reply. –  maxifick Oct 3 '12 at 20:03
add comment

1 Answer

This look suspiciously like this bug. There's a workaround explained on this page. They basically recommend to:

  1. Install WICD (System > Administration > Synaptic Package Manager; install wicd).
  2. Uninstall network manager (mark for complete removal network-manager and network-manager-gnome).
  3. Reboot.
share|improve this answer
    
Yes, the bug you linked looks just like this. However, I've still not been able to resolve it. I've updated the original post. Thank you for your reply. –  maxifick Oct 8 '12 at 0:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.