Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everytime I open a gtk application it outputs css warnings (lack of units assuming px etc). Can I disable this dreadful verbosity?

example:

$ gedit

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:3:14: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:52:20: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:72:19: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:102:14: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:102:16: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:105:20: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:129:16: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:130:17: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:141:20: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:142:19: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:149:14: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:168:19: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:169:20: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:182:19: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:196:20: Not using units is deprecated. Assuming 'px'.

(gedit:19558): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:207:19: Not using units is deprecated. Assuming 'px'.
share|improve this question

closed as off-topic by Eric Carvalho, waltinator, Alvin Row, mikewhatever, KasiyA Jan 24 at 17:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Eric Carvalho, waltinator, Alvin Row, mikewhatever, KasiyA
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Details? Please? –  user25656 Oct 2 '12 at 10:28
1  
Have you installed light-themes version 0.1.8.28.1 (at least) ? –  hakermania Oct 3 '12 at 12:38
    
I don't use light-themes. I like it dark as a prowling panther. Why is there 99 light themes in Ubuntu and no dark ones? There is the dark ambiance, but i don't want f*cking beige backgrounds. The contrasts stings my eyes like a green laser! Anyway this is highly unrelated to the question i asked... –  Simon Landeholm Oct 3 '12 at 15:31
    
This is part of a series of well known GTK theme bugs. While workarounds or patches may exist, discussion on bugs is off topic on AU. If an update to the most recent theme version doesn't help, please take the time and report the bug if nobody else did so far. –  David Foerster Oct 19 '14 at 20:36

2 Answers 2

up vote 1 down vote accepted

Well, I usually deal with that by redirecting stderr to /dev/null

gapp 2>/dev/null

Also, try the option --gtk-no-debug all

share|improve this answer
    
I case there is no option for this i guess this answers my question... :( –  Simon Landeholm Oct 11 '12 at 8:16
    
You can try also the option --gtk-no-debug all –  January Oct 11 '12 at 8:31
    
--gtk-no-debug all doesn't work. It doesn't hide the Gtk-WARNING –  Nicolas Feb 22 '13 at 14:52

I'm not sure if anyone else is still having this issue but I sure was. the solution is INCREDIBLY SIMPLE.

I run xfce4 on Arch Linux with the "dusk theme". I was getting this error for a gtk.css file on line 72.

By grepping the output of "find", I found the file in /usr/share/themes/Xfce-dusk/gtk-3.0/gtk.css.

On Line 72 I changed it from,

"text-shadow: 1 1 white;"

to

"text-shadow: 1px 1px white;"

Voila! No more annoying error messages!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.