Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am using Kubuntu 12.04, since Ubuntu 11.04 I am facing this problem.

Most of time my pointer's position changes to any random position itself and it start typing somewhere else and sometime content of last copied lined get pasted itself at current position. This spoils my text, I have to undo every time.

I am very sure that I don't touch my Touchpad.
What can be wrong? Please suggest.

share|improve this question

4 Answers 4

I've had a similar experience on my Dell Vostro laptop, it turns out my touchpad was set to be so sensitive, even just my palm floating a millimetre above it would trigger a click-action. The solution for me was to reduce the sensitivity of the touchpad, but I'm not sure that works on all machines though. Funny thing is, I had the same problem in Ubuntu 11.04 and Windows 7 64-bit and it was very frustrating indeed.

A work-around might be to use a USB mouse (with the touchpad disabled completely, in the BIOS), just to see if it resolves the problem. That way, you can be sure of where the problem is. Once you know it's the touchpad, you can see if tweaking the settings solves the problem.

share|improve this answer
    
I've had the same experience. –  John S Gruber Oct 10 '12 at 4:16
    
@JohnSGruber Did you have the same problem and found the same solution? –  Ewald Oct 10 '12 at 11:44

I have connected USB mouse to my laptop, because of I am not comfortable with Laptop touch pad. While typing in this setup, I used to touch Touchpad unintentionally. This was changing the typing cursor to some other position. For this the below fix works for me.

%synclient TouchpadOff=1

This command turn off the Touchpad. To enable it again I used below command

%synclient TouchpadOff=0

Thanks,

Shivu

share|improve this answer

I've had the same sort of experience. This is what I do to deal with it (it's part of my "install a new Ubuntu version recipe").

Create the /etc/X11/xorg.conf.d directory. In that directory create the file /etc/X11/xorg.conf.d/70-synaptics.conf with the following contents:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "PalmDetect" "1"
    Option "PalmMinWidth" "5"
    Option "EmulateTwoFingerMinZ" "5000"
EndSection

Some also use a program that locks the touchpad for a couple of seconds each time a key is pressed--this is not an uncommon problem.

It's the options in the above stanza that do the trick. Your situation may vary because you have different hardware than me. Even if it works for you it may be necessary for you to adjust the values due to a different touchpad/keyboard geometry, different hand size, etc.

share|improve this answer

I have similar experience while using Ubuntu 14.10: cursor jumps around whenever I brush my palm against the touchpad.

I've tried a number of approaches to resolve this. First, I can go into "System Settings" => "Mouse & Touchpad" panel and turn the touchpad off. That works, but I'm afraid of what happens if/when my mouse dies or I forget to take it with me. (It's a wireless mouse.) So I'm trying to write a toggle script.

First approach was toggling 'synclient TouchpadOff' status. I found that using 'sudo synclient TouchpadOff=<0|1>' temporarily set a new status (confirmed by immediately doing 'synclient | grep TouchpadOff'), but afterward changes between 0 & 2 (when looping on this query).

So I'm using the this approach: enable: xinput --enable disable: xinput --disable where 'dev_id' is found using 'xinput list' and searching for an appropriate entry. (My synaptics touchpad was listed as 'MSFT0001:00 06CB:75BD UNKNOWN' w/ id=13.) This seems to work (turn touchpad off|on), but doesn't appear to set TouchpadOff status (remains at 2), so I cannot really write an effective toggle function. Also, using xinput seems to conflict w/ using the "Mouse & Touchpad" gui, so if I've disabled it using xinput, I found that I have to toggle it off then on in the gui to get it back in sync. Sigh... Still, the purpose of the script should be to turn it back on if/when the mouse is MIA.

Next step is to put it somewhere (Launcher?) so that I can get to it thru keyboard strokes should my mouse not be available.

I believe that Microsoft's solution is to allow the touchpad to be disabled when a mouse is detected, but will immediately turn it back on when no longer detected. (I think that's how it works...) Also, working under Windows 8.1, I find I've not had to deal with the touchpad sensitivity much at all, so they must have set proper parameter values for the touchpad. Maybe Ubuntu could add a similar option to Mouse & Touchpad dialog panel, to turn off the touchpad whenever a mouse is detected. Tough part would be to turn it back on if mouse is no longer detected. Thoughts???

Finally, does anyone know if there's a way to detect/determine the brush of one's palm and basically ignore it? I turned PalmDetect on, but don't know what values to use for PalmMinWidth and PalmMinZ to effectively desensitize the touchpad when a palm brush happens. Any suggestions? I've set them both to large (500) and small (5) values, but still when I'm typing the cursor jumps, sometimes completely out of the window, sometimes to other locations in the current document. Any suggestions??? I'd love to have the option of using the touchpad, but its hypersensitivity to palm brushes is driving me crazy!!

I'm going to finish my script using 'xinput --disable' (difficulty recognizing which device is listed by 'xinput list'...), dock it somewhere, read up on keyboard shortcuts, then test out the scenario of mouse battery going dead or unplugging the usb sender from my laptop. If anyone has any further suggestions, I'd be willing to try them. (Haven't yet tried the /etc/X11/xorg.conf.d/70-synaptics.conf suggestion listed above; I'll probably try that tomorrow.)

BTW, on my old laptop, I was running Slackware using fvwm2, could never figure out how to turn off the touchpad, so resorted to a low-tech solution: covered the entire touchpad with a thin piece of metal taped on w/ duct tape!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.