Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to install any package in Ubuntu 10, I type the command

sudo apt-get install vlc 

and also the command

sudo apt-get update 

but I get this error every time

unable to locate package vlc

I tried sudo apt-get update again but I still get the same error.

Please help me. Is there something I have to change in the repositories? Please give some suggestions.

share|improve this question
    
Namasthe. could you provide what's the error ? –  Raja Oct 2 '12 at 8:04

4 Answers 4

Hi you can install vlc very easily in ubuntu .

open your unity dash and type software center . it will give you that named application and click it to open .

there in software center you'll find a search box at left top .

there type as vlc and you will get it .

select it and you'll get an option to install and click that install button .

there you go .

hope that helps .

share|improve this answer
1  
this did it for me. apparently the "universe" source is disabled by default for livecd, so it always said unable to locate package vlc –  rogerdpack Nov 29 '13 at 22:39

Please refer to http://www.videolan.org/vlc/download-ubuntu.html

You'll find ways to install vlc in it. However the site gives the following warning;

Ubuntu 10.04 LTS (lucid)

VLC version 1.0.6 in Ubuntu 10.04 is severely out-of-date. We recommend you install VLC 1.1.x manually.

You can manually add the ppa from terminal and install it.

Install VLC 1.1.4 in Ubuntu 10.04

Open the terminal and run the following commands

sudo add-apt-repository ppa:lucid-bleed/ppa
sudo apt-get update
sudo apt-get install vlc
share|improve this answer
    
@August : Priyanka has mentioned that she uses Ubuntu 10(either 10.04/10.10), I don't think unity comes shipped in by default in these versions. –  linuxandunix Oct 2 '12 at 8:46
    
@saisivasundar : I agree with your method as "VLC" is available in one of the universe repositories, butthe version for Ubuntu 10.04/10/10 will be severely outdated. –  linuxandunix Oct 2 '12 at 8:49

Use gksudo gedit /etc/apt/sources.list.

Find these lines in that file.

#deb http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
#deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
#deb http://archive.canonical.com/ubuntu lucid partner
#deb-src http://archive.canonical.com/ubuntu lucid partner

Now remove the # to include these repositories and save it. The lines should now look like this:

deb http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
deb http://archive.canonical.com/ubuntu lucid partner
deb-src http://archive.canonical.com/ubuntu lucid partner

Run sudo apt-get update and then sudo apt-get install vlc vlc-plugin-* mozilla-plugin-vlc.

share|improve this answer

Temporarily change your repositories server to somewhere else and update the apt-get list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.