Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This only happens with one of my computers. It is an elderly laptop that has had a long and varied history with several operating systems, but in its retirement it is acting as a server for my home network using Ubuntu 12.04. It is a single-boot system, there are no other systems installed. Every so often, whenever there is a grub upgrade, I notice a message like this:

Setting up grub-common (1.99-21ubuntu3.4) ...
Installing new version of config file /etc/grub.d/00_header ...
Setting up grub2-common (1.99-21ubuntu3.4) ...
Setting up grub-pc-bin (1.99-21ubuntu3.4) ...
Setting up grub-pc (1.99-21ubuntu3.4) ...
/usr/sbin/grub-setup: warn: Sector 32 is already in use by FlexNet; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.

Should I be worried about this? What (if anything) should I do about it?

share|improve this question
up vote 17 down vote accepted

It's not a big deal since there is no error reported so just warning.

But, if you wish to get rid of this, you need to wipe sector 32. To do this you have many choices:

a. Wiping the whole hard disk;

b. writing zeros to Whole sectors in your MBR and reinstall your grub;

c. Writing zeros to sector 32 in your MBR (that's what we'll do here).

To do that follow the following steps:

  1. Backup your MBR:

    sudo dd if=/dev/sda of=~/first_63_sectors bs=512 count=63
  2. zero your sector number 32:

    sudo dd if=/dev/zero of=/dev/sda bs=512 count=1 seek=32
  3. chroot and reinstall grub:

    sudo mount /dev/sda* /media/sda*
    sudo mount --bind /dev /media/sda*/dev
    sudo mount --bind /proc /media/sda*/proc
    sudo mount --bind /sys /media/sda*/sys
    sudo chroot /media/sda*

    PS: replace * by the appropriate number of your hdd

    Now update your grub:

    sudo update-grub

Note: You are not obliged to these steps, since its not an error that may affect your system.

share|improve this answer
Thanks maythux. Further info about this in my own answer (especially what to do when things go wrong...) – Bobble Oct 2 '12 at 7:04
I think you are right, 'leave well alone' was an option here, but at the same time I figure the warning is there because in the future it will cause a problem, so it's better to get rid of it. – Bobble Oct 2 '12 at 7:08
You are welcome and ive read your answer its great u deserve +1 – user61928 Oct 2 '12 at 7:09
This didn't worked for me. I tried even this. I'm still greet with the grub bootloader. – machineaddict Aug 11 '14 at 12:30

I found a couple of useful links that explain what the message is about, and how to clean out the boot sectors on the disk. This thread gives a very good explanation of the problem. This thread gives a nice easy cookbook recipe for cleaning things up.

The cookbook worked for me, although I made a mess of the chrooting bit... (see below)

I am lucky in that my computer is single-boot and I have no plans EVER to re-install Windows. But it seems that if you have a dual-boot Windows system with software that uses FlexNet or similar software, you can expect to have regular problems. Also I think some Windows viruses may use this part of the disk. The first thread discussion offers a solution for Ubuntu users, to install an app called boot-repair on your live-CD USB booter.

I also found the boot-repair program referred to above invaluable when things go wrong. IMHO this is so useful it should be on the Live CD by default. See this link.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.