Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am setting up a new user let his name be ftpguy. He has access to only one directory /var/www/xxx. I have already chowned the directory so that he has write and read privileges. The user is also unable to login via ssh as I have disabled that by changing his shell to /sbin/nologin.

Also, in vsftpd config, I have enabled the chroot_local_user. Now whenever I log in from ftp, i get an auth error.

Connect socket #1008 to xxxxxxxx, port 21...   
220 Welcome to blah FTP service.  
USER ftpguy  
331 Please specify the password.  
PASS **********  
530 Login incorrect.

I changed the password to something different several times, using the passwd command, nothing happens, i still the above error.

However I am able to log in with my ssh creditals to my ftp server without any problems.(I do not use a key).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I ran across this while letting my friend piggy back off my vps. I had to set his shell to a real shell instead or /bin/false or /bin/nologin. I then used the DenyUsers option in sshd_config to prevent him connecting via ssh.

It may be a bug with VsFTP but I didnt have time to get to the bottom of it yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.