Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So after installing JACK and using 'sudo usermod -a -G audio username' and restarted. This made JACK work however no program using pulseaudio (more or less everything) made any sound. I purge removed Pulseaudio, restarted, reinstalled it, restarted and finally the sound was working again. The only place sound won't come from is the test area in sound preferences.

I realise that performing a command I know little about was daft and that those test sounds aren't of very high importance, but I like things to run as intended. If anyone can help, it'd be very appreciated.

Thanks in advance.

share|improve this question
    
What version of Ubuntu? I think there were problems with the alert sounds in 11.10 while running Compiz. Also, there is a volume control that only affects alerts somewhere in the sound settings, so make sure it's not muted or set to minimum. –  Marty Fried Oct 2 '12 at 2:16
1  
I'm running the 12.10 Beta, upgraded from 12.04. I've made sure that isn't muted. –  Ross Oct 2 '12 at 13:20
    
Sorry, I'm out of ideas. I am running 11.10, and somehow seem to have fixed it, but I don't remember doing so. I do remember it didn't work at one point, but I don't know if it got fixed or if I fixed it somehow. Sorry. –  Marty Fried Oct 2 '12 at 19:09
add comment

1 Answer

When you uninstalled pulseaudio, other programs and libraries were removed as dependencies. To find out what they are (so you can reinstall them) look at the log.

The log is located here: /var/log/dpkg.log

Look for the line that contains "remove pulseaudio" (without the quotes) Above that line you will see what was removed as a dependency, here's what I found:

projectm-data
paprefs
libftgl2
libprojectm2
libprojectm-qt1
projectm-pulseaudio
libcanberra-pulse
indicator-sound

You can install these items with the following command:

sudo apt-get install projectm-data paprefs libftgl2 libprojectm2 libprojectm-qt1 projectm-pulseaudio libcanberra-pulse indicator-sound

The one causing your particular issue is libcanberra-pulse

indicator-sound is the one that shows a volume icon at the top in Unity

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.