Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am experiencing annoying automatic backlight brightness changes under ubuntu 12.04 LTS on my Dell XPS ultrabook.

It seems to be connected to the amount of white pixels on the screen (switching back an forth between dark/light application windows makes the effect noticable, but also just scrolling through a website.) So I think it is the dynamic contrast feature of the notebook screen.

How do I turn this off in Ubuntu? Windows offers specific Intel driver options for this, but I can't find any for Ubuntu.

Model: Dell XPS 14 Ultrabook and currently running Unity

share|improve this question
    
could you please provide with the exact model of your Laptop and your Window Manager? (KDE,Unity?) –  George Katsanos Oct 5 '12 at 11:41
    
@Jorge, please respect the post content, this question is referring to a Dell XPS 14, so your edit for the title is redundant. –  Eliran Malka Jan 26 '13 at 13:25
1  
Sorry, I was cleaning up the Dell XPS 13 questions and made a mistake! –  Jorge Castro Jan 26 '13 at 15:24
add comment

2 Answers

up vote 5 down vote accepted

Reproduced on a Dell XPS 13[1], there seem to be a real problem stemming from a collision between the graphics drivers, constantly calling the screen's brightness auto-adjust and causing the screen to flicker. See this bug report on another related issue (regarding broken functionality of function keys out of the box) that suggests a solution to the flickering problem as well;

The fix to both issues is offered by Kamal Mostafa from the Canonical Hardware Enablement Team as part of the Sputnik [2] Kernel PPA, while an independent earlier patch targets the function keys issue only (it is best, of course, to update with the former).


[1] I happen to own an XPS 13 model, and incidentally installed the 12.04 the day I got it... This is not a Sputnik machine, however (see [2]).

[2] The Sputnik project was Dell's effort to market a developer oriented edition of the Dell XPS 13 laptop, pre-installed with Ubuntu 12.04, and packed with developer-targeted goodies

share|improve this answer
    
Works like charm. Thank you very much! –  Rock Oct 11 '12 at 14:10
    
don't thank me, thank Kamal :) –  Eliran Malka Oct 11 '12 at 14:15
    
could somebody link me to how some instructions with how to install the Sputnik Kernel PPA from launchpad.net as linked above –  david_adler Apr 15 at 16:05
    
sorry, @david_adler, i didn't actually installed that kernel, just patched the existing kernel, so i have no clue how to install it. –  Eliran Malka Apr 15 at 16:51
    
@EliranMalka that's what I want to do also. Tried sudo add-apt-repository ppa:canonical-hwe-team/sputnik-kernel and then sudo apt-get update but no luck. How did you patch the kernel? –  david_adler Apr 16 at 16:54
show 1 more comment

According to DELL,

"this is part of the "Dell battery-saver" program, and it can be disabled through the preferences."

http://www.pcworld.idg.com.au/review/notebooks/dell/xps_14_l421x_ultrabook_review/429607

Investigate whether going to your Energy options of Unity or KDE and putting everything on maximum performance/no saving energy disables it. Otherwise, maybe there is a switch for the display or monitor driver.

Another place to look at would be the BIOS.

Also, if you have Nvidia and the Nvidia driver (and the Nvidia-settings application) you should look there.

share|improve this answer
1  
No options in BIOS, none in Unity performance or energy options either. I think it is a driver flag/signal (independent from the current backlight value) but I don't know where to look for the correct one. Nvidia card is turned off by bumblebeee. –  Rock Oct 6 '12 at 0:45
    
turn it back on, the Nvidia-settings might help you –  George Katsanos Oct 6 '12 at 6:47
1  
I have an Nvidia-Optimus GPU here, that means all my graphics are routed through the intel GPU and therefore I cannot access the nvidia settings correctly (driver not "really" active). So that does not help :-/ –  Rock Oct 7 '12 at 22:44
    
I have the same and the driver and the settings work fine. Did you try installing the latest latest driver? (the one in beta) –  George Katsanos Oct 8 '12 at 4:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.