Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought the dlink dwa-160 usb adapter a few days ago and i could not get it work. I tried using windows wireless drivers and it found the device but no communication was made. I also tried to use wine to run the installation CD but it couldn't find my hardware. I am alright at computers and i am new to Ubuntu can someone please give me detailed instruction on how to get it to work. Thanks.

share|improve this question
    
I'm puzzled how did you used windows drivers on linux? Through ndiswrapper? –  LnxSlck Oct 1 '12 at 21:54
add comment

1 Answer

I have a similar issue. First, looking here: http://wireless.kernel.org/en/users/Devices/USB It looks as though the B2 revision is not supported yet.

On my 12.04.1/mint installs out of the box nothing is recognized.

The best thing I've found is this: http://bernaerts.dyndns.org/linux/229-ubuntu-precise-dlink-dwa160-revb2

On mine, it gets the device recognized and working, but so far it has a tendency to drop the connection when idle for more than a 30-ish seconds in such a way that it has to be re-plugged in to connect again.

Based on that tutorial is looks like it's possible to tweak in order to achieve more stability, but I'm not sure I'll bother.

share|improve this answer
    
I tried that guide, but I'm stuck at the make and make install stages: Error 2 –  Canadian Luke May 12 '13 at 22:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.