Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hardware:

  • Intel i7
  • AMD Radeon HD 6970
  • SSD with plenty of space
  • 6 GB RAM

Software

  • OpenJDK 6, 7, and Oracle Java 7 (reproducible with all three)
  • AMD Catalyst 12.8 and open source driver (reproducible with both)
  • Ubuntu 12.04 x86_64 and older
  • Minecraft 1.3.2 vanilla and older

On this setup I am getting rubbish frame rates after a short while of playing, dropping from about 45-55 to 15 in a couple of minutes. CPU use is 40-45 even when rendering the opening screen at 1920x1280, and gameRenderer is using about 90% CPU when playing.

Rather than trying to eke out a few more FPS out of an obviously broken rendering pipeline, I really hope to find a solution to make the GPU render Minecraft.

Edit 1: Something bizarre just happened: The first thing I always change in the settings is to turn bobbing off. Turns out that re-enabling bobbing makes the frame rate shoot right back up from 15-20 to 30-50 (mostly around 30) in fullscreen mode! It is still rather erratic, bumping down to 15-20 sometimes, but usually only for a few seconds. Also, the debug mode (F3) shows that 100% of the time is spent in "unspecified".

Edit 2: That seems to have been a dud - I disabled bobbing again a few minutes later, and it's been running at 20-40 FPS since. The snooper reports 24 FPS.

share|improve this question
2  
AFAIK, minecraft is way more dependent on the CPU than the GPU. On that note, have you tried out optifine? It's supposed to increase FPS significantly. –  Glutanimate Oct 1 '12 at 22:05
2  
Minecraft uses LWJGL, a Java gaming library which run atop OpenGL. So, assuming your graphics card driver has full support for OpenGL under Ubuntu, it should already be rendering with the GPU. Aside from Optifine (and trying the 32-bit JVM - minecraft has issues under the 64-bit JVM in some setups), the only thing you can really do is turn down the render-distance. –  BlueRaja - Danny Pflughoeft Oct 1 '12 at 23:40
    
@Glutanimate With optifine it got a lot worse: 10-11 FPS even after turning off advanced OpenGL and setting tiny render distance. –  l0b0 Oct 2 '12 at 18:14
add comment

2 Answers

Check the amount of memory allocated allotted for mc to use; if its running in 32 bit mode it will only show max 2 or 3gb, if 64 bit mode how ever much memory you have - 1gb will be shown (option is only available in the launcher).

If your running a mod pack 4 gb is the max you will need. If its running 32 and you already have 64 then you have to uninstall 32 (there might be a fix,, I just don't know one). It is not sensible to run a 32 bit system with 6gb RAM + graphics.

share|improve this answer
add comment

Uninstall oricle java. I had the same problem (but with an even better gpu) and had the same java installs ,I removed oricle and my fps shot up from 20fps to 200fps 10 times better WOOOOO

share|improve this answer
    
Could you provide instructions for that? –  Seth Apr 15 at 19:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.