Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The ACER AO722 comes with an external mic input, and this input is not recognised by Alsa mixer or Sound (in System Settings). There are various comments on this problem, but no real solutions. For example External Mic not working but Internal Mic works on an Acer Aspiron AO722.

Using the internal mic is not an option, as I need to use skype professionally.

I have tried everything in alsamixer (accessible through the Terminal Ctrl+Alt+t, command: alsamixer), and in Sound (under System Settings). I have also installed Pulseaudio. But to no avail.

The headset is working normally under Skype in Windows. My AO722 came with Windows 7 on it, so I have installed Skype there too. My headset has separate connectors for ears and mic, and these go into the respective output and input on the right side of the laptop.

This location: http://bernaerts.dyndns.org/linux/202-ubuntu-acer-ao722 sounds like an effective solution but it is for Ubuntu Natty 11.04. The solution suggested sounds drastic to me: replace the kernel 2.6.38-13 with version 2.6.38-12. I use Ubuntu 12.04, and my kernel is 3.2.0-30-generic-pae. Question: could I try this solution with Ubuntu 12.04? Is this a risky thing to do?

I have found harware work around this problem. The audio output seems to be a combi output with also a microphone connection. I have made an adapter for this output. I used a 4 contacts 3,5 mm audio jack plug. To this plug I have soldered 2 female (common stereo) connectors, one for ears and one for the mic of my headset. The 4 contacts jack, which goes into the laptop (in audio OUTput) is wired as follows: tip = hot audio right; first sleeve after tip = hot audio left; second sleeve = common earth (for both ears and microphone); the 3rd sleeve = microphone signal input.

In the connector which I could buy, the 3rd sleeve is not so much a sleeve, but part of the metal base of the connector; normally you would expect this one to be connect to earth. But connecting the mic signal to it works. Maybe ready made adapters of this kind and even headsets with a combi jack can simply be purchased; I didn't check.

When I plug in the 4 contacts jack, Sound and Alsamixer immediately recognise an external microphone (even if no mic is connected to the adapter). In Sound, under the Input tab, 'Settings for internal microphone' changes into 'Setting for microphone'.

The microphone comes through loud and clear, however there is a constant noise in the background. Others have reported this too. If I disconnect the external mic from the adapter, or shortcircuit the external microphone, the noise gets less but does not disappear. Therefore, it is not background noise from the room, but it comes from the computer itself. However, if you talk directly in the microphone of the headset, the noise level is acceptable for VOIP.

The headset of my mobile phone Nokia C1 mobile comes wwith a 4 contacts combi 3,5mm jack plug. However, this one works (ear and mic) with the AO722 only if not inserted fully. Possibly the wiring of this headset jack is different.

I cannot find detailed specs of the AO722, and don't know whether the audio 'output' was actually designed as a combi input/output. I have seen that at least one other AO model has a combi connector only. In any case, I do not believe that connecting your headset in this way will harm your computer.

I would still appreciate a software solution. This must be possible, because the proper microphone input connector works under MS Windows.

share|improve this question
    
I wouldn't try to use a kernel that old with 12.04. –  John S Gruber Oct 9 '12 at 19:30
add comment

4 Answers

12.04

http://bernaerts.dyndns.org/%20http:/bernaerts.dyndns.org/linux/251-ubuntu-precise-acer-ao722

Once you have installed kernel 3.4, the sound card is fully recognised by default.

The only problem is that by default the internal microphone level is extremely low. It needs to be adjusted thru a microphone boost device....

share|improve this answer
add comment

First thing , I don't want to read so much I had the same experience that I couldn't detect my Microphone. If that is not the problem please repost the problem in a very short unit. Simply go to sound preference choose the duplex in the hardware setting menu. Done. Note: I forgot how was it , I did my best to reply to you , I am sure you will find what you have to .

share|improve this answer
    
Thanks for you answer. Sorry to write so much. Now, where do I find 'sound preference' ? –  Leeghwater Oct 15 '12 at 8:44
add comment

Yeah I have this issue too.

So I have found out how to work around it but not really a solution either. My guess removing pulseaudio will fix it but.... I don't want to do that.

My work around for now 1. Go to sound settings, then to input. You need to be able to see the microphone volume when, if it starts to work. 2. Now in a with the command line type alsamixer and press f4, if any of the microphone levels are low raise them 3. Notice that some of the levels say capture, using the spacebar toggle these around and after each check the other sound app if your microphone is working.

** if that works, you might be able to exit out, run as root alsactl store, to save the settings and then just run as root alsactl restore, set then back.

This is a pain in the rear but it works for me. If seems to me that Pulseaudio is controlling the sound but not working properly with the microphone.

Good luck

share|improve this answer
add comment

while i could occasionally get an external mic to work by the method described by user28525 above i needed something more relyable for participating on short notice online-meetings.

as i remembered having trouble with some mainline-kernels before (missing ubuntu-specific drivers or breaking other driver such as those provided by nvidia) i didn't really want to go down the path of jakars solution either.

luckily, i've found another helpful answer mentioning fully backported kernels for ubuntu-12.04-lts of which the latest is 3.8 (raring ringtail) and that just proved to work flawless so far as the input is switched automatically from internal mic to external mic as soon as i insert the jack. the sound-settings input-tab dialogue then also switches from internal microphone to microphone. the packages needed to install are linux-image-generic-lts-raring and linux-headers-generic-lts-raring and should be available in the standard ubuntu 12.04 repositories.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.