Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded our Ubuntu Server to 12.04.1 LTS. It runs a Xen VM, which is Windows Server 2008 R2 x64.

We are using the xl toolchain for Xen.

We are in the UK, which is currently GMT+1 (BST).

The time is correct on the host, i.e. it knows we're in BST.

tf@hostname:~$ date
Mon Oct  1 12:16:45 BST 2012

The time on the Windows guest keeps getting reset to GMT, i.e. 1 hour behind where it should be.

We had this on the previous Ubuntu release using the xm toolchain, which was fixed with the option localtime=1, however xl seems to ignore the localtime option.

I cannot find a mechanism to either:

  • get Xen to pass local time through to the guests with the xl toolchain

or

  • get Xen to leave the guest clock alone and allow NTP on the guest to keep things in sync.
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

From http://xen.1045712.n5.nabble.com/Time-is-off-by-an-hour-in-my-XEN-vm-tp2586195p2586196.html

There is a RealTimeIsUniversal registry flag hidden in the windows registry that can be set (its not in by default) to let Windows interpret the RTC as UTC as well.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] "RealTimeIsUniversal"=dword:00000001

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.