Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I reinstalled Ubuntu 12.04 on my laptop because the Unity desktop was freezing. Reinstalling 12.04 seems to have fixed the freezing problem, but now the audio does not work. When I go to Settings>Audio and under the Output tab it only has the option for Digital Output. There is no option for Analog Output. The sound card show up under lspci as: "00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)"

What would be the command to reinstall the audio subsystem? If that would fix it...

share|improve this question

2 Answers 2

Open the terminal and issue these commands from the terminal:

sudo add-apt-repository -y ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get dist-upgrade

sudo apt-get -y install linux-sound-base alsa-base alsa-utils libasound2

sudo apt-get -y install gdm ubuntu-desktop linux-image-`uname -r`

sudo apt-get -y --reinstall install libasound2 linux-sound-base alsa-base alsa-utils

sudo apt-get -y --reinstall lightdm ubuntu-desktop linux-image-`uname -r`

killall pulseaudio

rm -r ~/.pulse*

sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

When you finish, restart your system. If sound still missing from your system, you can check this article

share|improve this answer
    
I tried all the commands above and they didn't work, so I looked at the article you linked to and The last thing on the list worked!! Under "Onboard Realtek ALC887" sudo gedit /etc/modprobe.d/alsa-base.conf add at the bottom of the file opened with the above command: options snd-hda-intel model=generic I reinstalled Ubuntu again to recreate the same problem and I only did the above and that alone fixed it! –  user89756 Oct 4 '12 at 3:12
up vote 0 down vote accepted

The following fixed the problem in my case:

Enter in terminal the command: "sudo gedit /etc/modprobe.d/alsa-base.conf"

Add to the bottom of the file opened with the above command: "options snd-hda-intel model=generic"

Reboot the computer

The solution to my problem was on the page maythux linked to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.