Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to set up a socks5 proxy based on my ubuntu 12.04 server.

I've read that this is supposed to be easy and doable with one command:

ssh -f -N -D 0.0.0.0:1080 localhost

Not so much in my case (error message):

Permission denied (publickey).

After this, I've tried installing ss5.

First from source:

wget http://heanet.dl.sourceforge.net/project/ss5/ss5/3.8.9-7/ss5-3.8.9-7.tar.gz
tar -zxvf *.tar.gz
cd *
./configure

Which ended in

configure: error: *** Some of the headers weren't found ***

After which I attempted to install it from rpm, without much luck:

error: Failed build dependencies:
        openldap-devel is needed by ss5-3.8.9-6.i386
        pam-devel is needed by ss5-3.8.9-6.i386
        openssl-devel is needed by ss5-3.8.9-6.i386
        libgssapi-devel is needed by ss5-3.8.9-6.i386

....

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openldap-devel

There are other packages for socks5, but I've met similar problems with them too.

Can anyone point me to a good info on how to turn ubuntu 12.04 server into a socks5 proxy?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You can fix the first error easily:

Go into the dash, and search Passwords and Keys. Go into your keys and go to File>New and chose the SSH key. Don't give it a password. Then, set it to use RSA, any key size, and then when prompted to set it up to be used for logon, allow it to do so, and choose the following settings:

Hostname: localhost
Username: Your username

and give your password if prompted. Reboot and try again with the first command.

share|improve this answer
    
I'm doing this on server via ssh. Could you provide the commands for what you just said? –  Arsen Zahray Sep 30 '12 at 22:42
    
Just give the hostname and user on the server instead of localhost. Run the graphical program on your local machine, then try it again. –  hexafraction Sep 30 '12 at 22:45
    
Also, is the first error when you run the command,or try to connect? –  hexafraction Sep 30 '12 at 23:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.