Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba l755 laptop, and I installed 12.04 64bit on it. The default brightness of the laptop is set to maximum value, and I can't change it.

If I go to Configuration → Brightness, the brightness doesn't change and neither does pressing the function keys.

I tried changing some parameters of grub file, setting GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor".

When changing the brightness from configuration, the value of /sys/class/backlight/toshiba/brightess changes, but screen remains the same. If I use the key functions, it changes the "actual_brightness" files. I don't know what else can I do, any suggestions?

share|improve this question
    
I did not understand the last paragraph: So you change the value in the file but the"brightness" remains the same. and if you use the keys it will change the "value if actual brightness" in the file. This is what you wanted to say ? and I guess you don't have any problem with the keys ? –  Suhaib Sep 30 '12 at 15:45
    
In /sys/class/backlight/toshiba I have many files: "brightness" "max_brightness" "actual_brightness" which I can modify. But those files' values doesn't seem to really affect the actual screen brightness. –  albert Sep 30 '12 at 23:03
add comment

1 Answer

You can manually set the brightness from the command line using:

sudo echo 0 > /sys/class/backlight/acpi_video0/brightness

(You change the value from 0 to 100 for desired brightness.)

share|improve this answer
    
The thing is, I actually can change the value of it using function keys or from parameters, it's the screen that doesn't change the brightness. Moreover, I don't have the "acpi_bideo0" folder in backlight, just the "toshiba". –  albert Sep 30 '12 at 16:26
    
This worked for me! Albert, maybe you should remove all the options you added in the grub files (I didn't have any options). Then what I did was: sudo echo 50 > /sys/class/backlight/intel_brightness/brightness. –  thedoctar Jul 20 '13 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.