Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I moved my hdd to a new pc. The hardware is different from the old pc. I was able to get online yesterday, however not anymore today. I can see when I run ifconfig -a that it is telling me that I have eth0 and eth1. The old pc has 2 network cards, the new one only has one.

I am assuming that the issue is that it is looking for the mac of the old network cards and not the new one. I deleted the entries in 70-persistant-net.rules and it reprinted the same eth0 and eth1 on reboot.

The version is Ubuntu 11.04. I do want to upgarde to 12.04 however I dont have a cd rom and the new box isnt booting from a flash drive.

I tried running dhclient on both eth0 and eth1 and in both cases the waits for about 60 to 90 seconds and then just gives me the command line again without printing any information. I then go back to ifconfig -a and I now ever a new entry

ethx:avahi link encap:Ethernet and then eventually I see an inet address of which is an error address

Any suggestions on how to resolve this issue? Maybe it is a driver issue since I moved to the new box? It just doesnt make sense that I had internet yesterday and today I do not.


share|improve this question
I resolved this issue by adding another network card that I had. I guess the OS already has the drivers it needs for the external card. I still dont know why the on board one just stopped, but this solution works. Thanks. – terbor Sep 30 '12 at 15:32

If you plan to upgrade, why not simply configure your interface with a temporary static IP ? Ok, this is quick and dirty, but as you will launch distrib upgrade, configuration files will be update so...

Here is an example to up the interface eth0 with a static IP :

sudo ifconfig eth0

To stop the interface you can write :

sudo ifconfig eth0 down
share|improve this answer
I did try this already and when you run ifconfig -a it shows the static, but still it doesnt work. I did add to the resolv as well. One thing I noticed is that the light on the network jack on the comp doent turn on anymore. Which is why I think the OS doesnt recognize that the network card even exists. Thanks – terbor Sep 30 '12 at 14:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.