Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a thermal printer tm-t20 on 12.04 x64 with cups 1.5.3-0ubuntu4 and the Epson provided drivers tmt-cups-1.3.2.

The printer just prints garbage after the first print. If I turn it off and then on, it prints ok (the first Job), but if I send another job it prints just garbage. The printer is serial and I'm using an usb to serial converter, I tried with different adapter to discard an USB to serial converter issue.

At the cups web interface the following error is shown at job list:

Stopped 
"/usr/lib/cups/filter/pstopdf failed"

Part of the log:

[Job 15] Error: /dictstackunderflow in --end--

 [Job 15] Operand stack:
 [Job 15]
 [Job 15] Execution stack:
 [Job 15] %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2                   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1914   1   3   %oparray_pop   1913   1     3   %oparray_pop   1897   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --             nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--

 [Job 15] Dictionary stack:
 --dict:1174/1684(ro)(G)--   --dict:0/20(G)--   --dict:77/200(L)--
 Current allocation mode is local
 [Job 15] GPL Ghostscript 9.05: Unrecoverable error, exit code 1
 [Job 15] PPD uses qualifier 'Gray..203x203dpi'
 [Job 15] Calling FindDeviceById(tmt20)
 Failed to send: org.freedesktop.ColorManager.Failed:device id 'tmt20' does not exists
 [Job 15] Failed to get profile filename!
 [Job 15] no profiles specified in PPD
D [30/Sep/2012:00:25:21 -0300] [Job 15] Ghostscript command line: /usr/bin/gs -dQUIET -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOINTERPOLATE -    sDEVICE=cups -sstdout=%stderr -sOutputFile=%stdout -r203x203 -dDEVICEWIDTHPOINTS=204 -dDEVICEHEIGHTPOINTS=841 -dcupsBitsPerColor=1 -         dcupsColorOrder=0 -dcupsColorSpace=3 -dcupsRowCount=24 -scupsPageSizeName=RP80x297 -I/usr/share/cups/fonts -c -f -_
D [30/Sep/2012:00:25:21 -0300] [Job 15] envp[0]="CUPS_CACHEDIR=/var/cache/cups"

I tried downgrading and upgrading cups (installing manually), but I wasn't able to send nothing to the printer because cups wasn't working (errors everywhere).

Any idea?

share|improve this question

1 Answer 1

Finally after a lot of pain. I discover that the problem was the serial to USB cable (in order to connect the serial printer to an USB port). I tried with two different serial to USB cables, but the problem persists and finally I conclude that The printer works erratically if is not connect to a "real" serial port.

I tested the printer under identical conditions in a PC with a serial port and it works perfect, just installing the driver provided by epson and giving chmod 777 to /dev/ttyS0. At the job list sometimes I see the error: "/usr/lib/cups/filter/pstopdf failed". But the printer prints ok, like no error occurred.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.