Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my stock Ubuntu install (forgot which critter its named for, about one year old), I am able to boot up normally only if I manually select the kernel in the bootloader (Grub). If I step away and it boots from the default, the system will hang with the word "Ubuntu" on a graphics screen and a few white/red blinking dots beneath it.

uname -a

Linux digdug 2.6.32-42-generic #95-Ubuntu SMP Wed Jul 25 15:57:54 UTC 2012 i686 GNU/Linux

Synaptics says I have 'grub-pc' version 1.98-1ubuntu-13 installed.

My grub.cfg does have default="0" which I would expect to make the default be the first kernel shown in the selection screen.

The system is a laptop with an i7 processor, and I have had trouble with some kernels not being able to boot at all in the past, and power management is not working perfectly, but I have not had problems booting the latest kernel (2.6.32-42) if I select it manually in Grub.

Any idea what is going on here and how can I fix it so that I can re-boot unattended?

Edit

grub.cfg is on pastebin.

And so is /etc/default/grub.

Edit 2

Based on Sly's advice, I tried

mb@digdug:~$ sudo grub-mkconfig -o ./test.grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-42-generic
Found initrd image: /boot/initrd.img-2.6.32-42-generic
Found linux image: /boot/vmlinuz-2.6.32-41-generic
Found initrd image: /boot/initrd.img-2.6.32-41-generic
Found linux image: /boot/vmlinuz-2.6.32-40-generic
Found initrd image: /boot/initrd.img-2.6.32-40-generic
Found linux image: /boot/vmlinuz-2.6.32-39-generic
Found initrd image: /boot/initrd.img-2.6.32-39-generic
Found linux image: /boot/vmlinuz-2.6.32-28-generic
Found initrd image: /boot/initrd.img-2.6.32-28-generic
Found linux image: /boot/vmlinuz-2.6.32-24-generic
Found initrd image: /boot/initrd.img-2.6.32-24-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
Found Windows Vista (loader) on /dev/sda4
done
mb@digdug:~$ diff /boot/grub/grub.cfg test.grub.cfg
mb@digdug:~$ 

indicating, AFAICT, that grub-mkconfig has precisely reproduced my existing grub.cfg.

Is it possible that init somehow knows I've booted by default and has triggered some long disk tests or something that are making me think the boot is hung?

share|improve this question
    
Can you post the output from /boot/grub/grub.cfg and /etc/default/grub? –  Sly Sep 30 '12 at 3:39
    
@Sly, Done. But they're pretty long files, so I put them on pastebin. –  The Photon Sep 30 '12 at 4:00
add comment

1 Answer 1

It seems that your /boot/grub/grub.cfg is missing quite a bit compared to the one that I have in Ubuntu 12.10.

I would suggest copying your /boot/grub/grub.cfg file to your home directory, run grub-mkconfig to create a new GRUB config, and then compare the two files to see if there is any difference.

For example:

$ sudo cp /boot/grub/grub.cfg ~/test.grub.cfg
$ sudo grub-mkconfig -o ~/test2.grub.cfg
$ diff -qy ~/test.grub.cfg ~/test2.grub.cfg

Make sure that any changes that were made didn't remove your Windows partitions. Then you can either copy the new test2.grub.cfg over to /boot:

$ sudo cp ~/test2.grub.cfg /boot/grub/grub.cfg

Or you can just run sudo update-grub, which will run sudo grub-mkconfig -o /boot/grub/grub.cfg.

share|improve this answer
    
thanks for the advice. I tried essentially what you recommended and grub-mkconfig perfectly reproduced my existing grub.cfg...see edits in my question. Any other ideas? Or specifics on what is in your grub.cfg that I'm missing? –  The Photon Sep 30 '12 at 17:38
    
If your grub-mkconfig generated the same file, it doesn't really matter what mine looks like compared to your's. When I say mine looks different, it's a lot of insmod commands that are different. They may not be appropriate for what you're using. Especially since you're on the 2.6.x kernel, and I'm on 3.2.x. –  Sly Sep 30 '12 at 18:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.