Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Message says:

Failed to load the package list

This is a serious problem. Try again later. If this problem appears again, please report an error to the developers.  
Click details, which says:

E:Type 'http://ppa.launchpad.net/madman2k/ubuntu' is not known on line 61 in source list /etc/apt/sources.list  

Tried this solution:

sudo rm /var/lib/apt/lists/* -vf  
sudo apt-get update  

However, when entering the first command, it hits back an error:

rm: cannot remove `/var/lib/apt/lists': Is a directory

Some people are suggesting that I change settings in the update manager. I unfortunately can't, since the update manager closes each time I get the error.

Any other way to remove that package?

share|improve this question
    
Please use your existing account to perform edits so they do not have to go through the suggested edit queue. –  hexafraction Oct 2 '12 at 0:11

2 Answers 2

This problem is caused because the madman2k user's repositories have been removed from the PPA system. Try vising http://ppa.launchpad.net/madman2k/.

All you need to do is remove the line(s) for this PPA in your /etc/apt/sources.list.

Also, use sudo apt-add-repository in the future, so that your repositories are added into /etc/apt/sources.d/. This way, you can remove an invalid repository such as this one with just sudo apt-add-repository -r ppa:madman2k/ubuntu.

share|improve this answer

Open update manager, click on settings, open the "other software" tab, delete the ppa.launchpad.net/madman2k/ubuntu entry. Try again.

This usually happens when the ppa is no longer required and has been removed, or if it not available or required for a new Ubuntu release.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.